Opened 15 months ago

Last modified 15 months ago

#12565 new feature request

PRIVATE: Casebook inaccesible

Reported by: TrivialBalderdash Owned by: neuromancer
Priority: low Component: Engine: Private
Version: Keywords:
Cc: Game: Private Eye

Description

The casebook on the menu/radio/phone/map screen does not allow for reviewing choices made during the game. Locations are shown, and inventory can be accessed using the tab at the top, but none of the pages in between can be viewed. In the corner location to turn the page, only a down arrow is displayed, which returns to the main screen. (See attachment)

This is not required to complete the game, and almost feels like a bonus feature. Though someone might want to review their case history as they are trying to solve the case.

Attachments (3)

Casebook.png (1.9 MB ) - added by TrivialBalderdash 15 months ago.
Casebook2.png (576.8 KB ) - added by TrivialBalderdash 15 months ago.
nodups.diff (1.3 KB ) - added by neuromancer 15 months ago.

Change History (12)

by TrivialBalderdash, 15 months ago

Attachment: Casebook.png added

by TrivialBalderdash, 15 months ago

Attachment: Casebook2.png added

comment:1 by TrivialBalderdash, 15 months ago

Additionally, the list of locations links to the pages, as shown in the second attachment.

comment:2 by neuromancer, 15 months ago

You are right, this was never implemented and it is optional. Still, it's clear it is useful to review the case information during the game. I decided to prioritize the rest of the gameplay, since this feature is hardcoded in the binary and I had to understand how to how each decision is recorded (I suspect this is also hardcoded) and allow to replay each video.

by neuromancer, 15 months ago

Attachment: nodups.diff added

comment:3 by neuromancer, 15 months ago

Can you try that patch? (You will need to restart your game, old saves won't be useful)

comment:4 by TrivialBalderdash, 15 months ago

Ok, I gave this a try.

The inventory list in the casebook is blank. I can still collect inventory and it still is viewable in the cabinet in Marlowe's office. I played through part of the game, collecting more items, saving the game, reloading, then restarting ScummVM and reloading. In all cases the Inventory page of the casebook was blank.


Disclaimer: This is the first time I've attempted to compile ScummVM and also to apply a patch. My confidence in my ability to do this correctly is low.

I decided to use Linux (Debian). I cloned the repository -

git clone git://github.com/scummvm/scummvm.git

I downloaded the diff file to the directory just created and ran:

patch -p1 < nodups.diff

This did appear to update the funcs.cpp file.
Then:

./configure
make clean
make -j2

It seemed to complete correctly, since I could start ScummVM and run the game.

comment:5 by neuromancer, 15 months ago

Yes, I can confirm this. Your procedure is correct, I will send you another (better) patch soon.

comment:6 by neuromancer, 15 months ago

I identified the issue. It's failing to render some masks on master, so I will commit there a fix soon.

comment:7 by neuromancer, 15 months ago

I think this is fixed. To re-test from your scummvm cloned repository:

git checkout .
git pull
make -j2

Please let me know if the duplicated entries are gone (you will need to start a new game).

comment:8 by TrivialBalderdash, 15 months ago

Success! This seems to have resolved the duplicate inventory entries. I tried several combinations of saves, reloads, and restarts, and everything was displaying correctly.

And thank you for the git instructions! I appreciate the coaching as I'm learning how this works.

comment:9 by neuromancer, 15 months ago

Great, thanks for the testing. Please keep this issue open since the casebook is still not fully implemented.

Note: See TracTickets for help on using tickets.