Opened 16 years ago

Closed 16 years ago

#1256 closed defect (fixed)

FT: restore savegames

Reported by: SF/logicdeluxe Owned by: SF/ender
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

ScummVM 0.5.3cvs (Oct 1 2003 10:18:05)
When I try to load a savegame while a video cut scene
is playing, at the LucasArts logo for instance, this
has the same effect as pressing ESC and the game does
not load. Doing this in a normal scene works fine.

Ticket imported from: #815853. Ticket imported from: bugs/1256.

Change History (4)

comment:1 by fingolfin, 16 years ago

Problem confirmed.

comment:2 by SF/leerqbasic, 16 years ago

Also, sometimes when loading a savegame during a cutscene
(action scenes for instance) which bring you back just
before the cutscene starts, may screw up the actors. Looks
like not all variables are being reset, or something.

comment:3 by SF/ender, 16 years ago

Owner: set to SF/ender
Resolution: fixed
Status: newclosed

comment:4 by SF/ender, 16 years ago

This is because the intro smush is started from the
bootscript, and we usually clear saveLoadFlag right after
the bootscript terminates.

Changed to only clear it if we loaded an initial save
INSTEAD of running the bootscript.

Note: See TracTickets for help on using tickets.