Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#12552 closed defect (fixed)

SCUMM: 2 verbs on the left do not work anymore

Reported by: michas0602 Owned by: bluegr
Priority: high Component: Engine: SCUMM
Version: Keywords: verbs defect
Cc: Game:

Description

Hi, tried a current dev-version (build 14/05/21)
on my Raspberry Pi, and in some Scumm-engine games (DOTT, Monkey Island) 2 verbs on the left do not work anymore, so they are not completeable atm.

I cant click them, whatever I do using fullscreen, have not checked windowed mode.

Not sure what exactly could causing this, some other games I tried are fine. When I am not wrong, Indy 4 is also affected here.

Attachments (1)

Screenshot 2021-05-16 at 20.34.01.png (1.2 MB ) - added by criezy 12 months ago.

Download all attachments as: .zip

Change History (7)

comment:1 by criezy, 12 months ago

I have verified that the issue occurs on macOS with Day of the Tentacle (French Mac version). When the cursor is on the first column of verbs, the game think it is on the second column.

A bisection indicates that this issue was introduced in commit c8fc484c3 - SCUMM: Fix X-range of selection for Hebrew on scumm<7

Note: the games are actually still completable if you known the shortcuts for the verbs since those still work (e.g. O for Open / Ouvrir).

comment:2 by bluegr, 12 months ago

Summary: 2 verbs on the left does not work anymoreSCUMM: 2 verbs on the left do not work anymore

comment:3 by bluegr, 12 months ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:4 by orgads, 12 months ago

@bluegr: Thanks for the quick fix, but this is not a good solution. The issue is also relevant to Hebrew.

I'll look into it.

comment:6 by criezy, 12 months ago

The pull request from orgads was merged and I have verified that DOTT works properly for me now.

Note: See TracTickets for help on using tickets.