Opened 17 months ago

Closed 2 months ago

#12518 closed defect (fixed)

AGS: Whispers of a Machine - Company logos not vertically centered & show main menu background at bottom

Reported by: Thunderforge Owned by: criezy
Priority: low Component: Engine: AGS
Version: Keywords: whispersofamachine
Cc: Game:

Description

When starting up Whispers of a Machine (whispersofamachine), the company logos appear differently in ScummVM than in the original game.

Expected behavior

The company logos are vertically centered with black bars above and below.

Tested with macOS Steam

Actual behavior

The company logos begins at the top of the window and, instead of black bars, the main menu background is visible.

Tested with 6 May macOS x64 daily build (ab8c4cc5)

Attachments (2)

Original Game Logos.png (189.5 KB ) - added by Thunderforge 17 months ago.
ScummVM Logos.png (253.1 KB ) - added by Thunderforge 17 months ago.

Download all attachments as: .zip

Change History (6)

by Thunderforge, 17 months ago

Attachment: Original Game Logos.png added

by Thunderforge, 17 months ago

Attachment: ScummVM Logos.png added

comment:1 by criezy, 17 months ago

I just tried with the AGS 3.5 interpreter and it behaves in the same way as ScummVM. So this issue is not specific to ScummVM. Whispers of a Machine is known to use a modified AGS engine. We ported some of the changes to ScummVM, but it is possible that the difference is caused by some changes we did not include.

The source code for the modified engine is available at https://github.com/josthas/WoaMAGS/ in case somebody wants to try to find out what changes it has that could cause this.

comment:2 by dreammaster, 14 months ago

Priority: normallow

Marking these as low priority, since they're existing issues in the stand-alone interpreter. This should make it easier to keep track of upstream problems vs ones introduced in ScummVM

comment:3 by criezy, 2 months ago

The same bug was reported in upstream AGS and there is more information about it there:
https://github.com/adventuregamestudio/ags/issues/868

The change that seems relevant in the engine used for that game is the resolution of 640x360 instead of 640x400.
https://github.com/josthas/WoaMAGS/blob/master/Engine/main/graphics_mode.cpp#L212

And indeed I have checked that forcing the resolution to be 640x360 in ScummVM fixes the issue.

comment:4 by criezy, 2 months ago

Owner: set to criezy
Resolution: fixed
Status: newclosed

I have added a hack to get the correct resolution for this game, and this fixes the issue.

Note: See TracTickets for help on using tickets.