Opened 5 months ago

Closed 3 months ago

#12510 closed defect (fixed)

AGS: Ben There Dan That: Crash when leaving the Spaceship Hub

Reported by: ahem Owned by: dreammaster
Priority: normal Component: Engine: AGS
Version: Keywords:
Cc: Game:

Description

SCUMMVM Version: 2.3.0git15941-ge000b92ab9 (May 2 2021 10:07:16)
Game: "Ben There Dan That"

When leaving the alien spaceship hub through the first door, the game crashes with the error !SetObjectFrame: invalid frame number used (0, range is 0 - -1)!.

This bug makes the game unwinnable (and unplayable, since it happens pretty near the beginning and is impossible to avoid).

I have attached a save game right before entering the door which causes the crash.

Attachments (1)

bentheredanthat.003 (641.5 KB ) - added by ahem 5 months ago.

Download all attachments as: .zip

Change History (2)

by ahem, 5 months ago

Attachment: bentheredanthat.003 added

comment:1 by dreammaster, 3 months ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

Confirmed the bug doesn't happen with the new codebase.

Note: See TracTickets for help on using tickets.