Opened 16 years ago

Closed 16 years ago

Last modified 10 months ago

#1251 closed defect (fixed)

ALL: hanging when quit while MIDI is playing regression

Reported by: SF/logicdeluxe Owned by: SF/jamieson630
Priority: normal Component: Audio: MT32
Keywords: Cc:
Game: Monkey Island 2

Description

ScummVM 0.5.3cvs (Sep 28 2003 11:05:44) using Windows
When I start a game using MIDI music, ScummVM hangs
when I try to quit while the game is currently playing
MIDI music. No matter if it is done with alt-x or
within the F5 menu. GM or MT-32 doesn't matter either.
In order to reproduce it, just quit ScummVM while the
title sequence is running in Monkeyvga or Monkey2 for
instance. ScummVM hangs then. Doing this at the Melee
dock in Monkeyvga or at the copy protections in
Monkey2, ScummVM quits fine. Using "imuse panic" in the
console and quit then also works fine.
There is no error message. It did not happen with
ScummVM 0.5.3cvs (Sep 27 2003 16:36:24)

Ticket imported from: #813920. Ticket imported from: bugs/1251.

Change History (11)

comment:1 Changed 16 years ago by fingolfin

Can't reproduce on OS X.

comment:2 Changed 16 years ago by fingolfin

Owner: set to SF/jamieson630

comment:3 Changed 16 years ago by SF/logicdeluxe

This is a native MIDI issue. It does not happen with Adlib
emulation.

comment:4 Changed 16 years ago by fingolfin

Fine. That's good. Because I am *not* using adlib emulation :-)

comment:5 Changed 16 years ago by SF/jamieson630

Probably related to the switch from threads to the timer
services. What backend are you using, logicdeluxe? I'm not
getting any crashes or lockups under Win32/SDL with native
MIDI, either, but the timer services of other backends might
still be an issue.

comment:6 Changed 16 years ago by SF/jamieson630

Resolution: fixed
Status: newpending

comment:7 Changed 16 years ago by SF/jamieson630

Okay, I got it to hang on dottdemo. (Why don't we have a
link to this from scummv.org, BTW?) Fix is in CVS. logicdeluxe,
since you can get it to hang in places I can't, please verify
the fix and post results here. Thanks.

comment:8 Changed 16 years ago by SF/logicdeluxe

Works again.

comment:9 Changed 16 years ago by SF/logicdeluxe

Status: pendingnew

comment:10 Changed 16 years ago by SF/jamieson630

Status: newclosed

comment:11 Changed 10 months ago by digitall

Component: --Unset--Audio: MT32
Game: Monkey Island 2
Note: See TracTickets for help on using tickets.