Opened 16 months ago

Closed 6 weeks ago

#12509 closed defect (fixed)

TINSEL: memory corruption with DW1 V0 floppy demo

Reported by: dwatteau Owned by: dwatteau
Priority: normal Component: Engine: Tinsel
Version: Keywords:
Cc: Game: Discworld

Description

ScummVM shows a memory corruption issue when launching and quitting the original V0 floppy demo of Discworld 1 (dw-dos-floppy-demo-en.zip).

This is on a ppc32 big-endian Debian system.

To reproduce:

  1. Build tinsel from current HEAD sources (e60e0b8f20f8ff05a355ee8ac0fb7d8c2bc35668 at the moment).
  2. Get dw-dos-floppy-demo-en.zip from the Demos page, and launch it in ScummVM.
  3. Once the game starts, just close the ScummVM window, in the title screen or in the first scene.

glibc shows a corrupted size vs. prev_size error in the terminal.

Attached are gdb and Valgrind logs.

Attachments (2)

tinsel_gdb_memory_corurption_v0_ppc.txt (3.7 KB ) - added by dwatteau 16 months ago.
valgrind_scummvm_tinsel_v0_ppc.txt (9.6 KB ) - added by dwatteau 16 months ago.

Download all attachments as: .zip

Change History (5)

by dwatteau, 16 months ago

comment:1 by eriktorbjorn, 13 months ago

Unfortunately I can't seem to reproduce this on my 64-bit little-endian Debian system. At least not with the current development version.

comment:2 by dwatteau, 6 weeks ago

Indeed, with all the changes in this engine in the last year, I can't reproduce this problem anymore with today's Git HEAD version on the same machine.

Closing this, then.

comment:3 by dwatteau, 6 weeks ago

Owner: set to dwatteau
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.