Opened 3 years ago

Closed 8 months ago

#12506 closed defect (fixed)

ULTIMA8: Half-hardened lava causes no damage

Reported by: cefotaxime Owned by: OMGPizzaGuy
Priority: normal Component: Engine: Ultima
Version: Keywords:
Cc: cefotaxime Game: Ultima VIII: Pagan

Description

In the original game, Avatar can only walk on half-hardened lava terrain with 'Endure Heat' magic on. Under the Scummvm Engine, however, Avatar can simply jump on that terrain unharmed, making 'Endure Heat' magic useless.

Attachments (1)

K-001.jpg (146.1 KB ) - added by cefotaxime 3 years ago.

Download all attachments as: .zip

Change History (4)

by cefotaxime, 3 years ago

Attachment: K-001.jpg added

comment:1 by digitall, 3 years ago

Keywords: lava damage removed
Summary: Half-hardened lava causes no damageULTIMA8: Half-hardened lava causes no damage

comment:2 by mduggan, 3 years ago

I think this is basically caused by the same thing as #11955, but there may be a second related problem:

  1. For #11955, the Avatar doesn't fall as often as he should, because his hitbox is quite large and we use the larger hitbox to calculate fall. Quite often that overlaps with a neighbouring tile.
  1. I think there may also be another problem with hit events - jumping to a specific piece of lava does not cause any damage either.

comment:3 by OMGPizzaGuy, 8 months ago

Owner: set to OMGPizzaGuy
Resolution: fixed
Status: newclosed

MainActor::Teleport 24 19187 28491 0

Jumping on this tile now causes damage, but if damage animation ends on the same tile, it can prevent taking additional damage.
Full fix would probably be adjusting sweep test to not exclude overlapping start items beneath player.

Note: See TracTickets for help on using tickets.