Opened 16 years ago

Closed 16 years ago

Last modified 13 months ago

#1250 closed defect (worksforme)

ALL: Mouse clicks limited area

Reported by: SF/donaciano11 Owned by: fingolfin
Priority: normal Component: Port: Mac OS X
Keywords: Cc:
Game:

Description

ScummVM 0.5.3cvs (Sep 26 2003 23:43:29)
OS X build on Jaguar 10.2.6 using gcc 3.1
English DOTT, BASS, MI1, MI2, DIG...

Cursor moves freely and objects are listed as usual, except
that clicks do not get through, neither right or left button. All
are confined to the double sized screen limits. This is true
for 3x scaled or the new hq3x whatever mode. However if
changed to full-screen and back to windowed, it is cleared
up. And after any window size changed after going full
screen will use the correct screen limits.

Not sure when this showed up, only my 2nd build, it was
there yesterday also.

Hi everyone. :o)

-Don.

Ticket imported from: #813426. Ticket imported from: bugs/1250.

Change History (5)

comment:1 by eriktorbjorn, 16 years ago

I can't reproduce this under Windows. Haven't tried it under
Linux yet.

comment:2 by SF/donaciano11, 16 years ago

Okay I just tried this one with the Sept 27th Windows daily build
and it's not in there at all, also the Sept 24th is fine. Seems OS X
only.

comment:3 by fingolfin, 16 years ago

All I can say for now is that I have no such problems on OS X. But
then the problem description is very vague and incomplete, so it's
hard to tell. What resolution is your screen, are you using full
screen or windowed mode, which scaler do you use, precise steps
to reproduce your problem, etc.

If you provide this information, we can check if the "problem"
(whatever it is) is reproducible here or not.

Oh yes, the SDL version isn't mentioned either... make sure to use
SDL 1.2.6, there was at least on mouse related bug in previous
versions on OS X.

comment:4 by fingolfin, 16 years ago

Owner: set to fingolfin
Resolution: worksforme
Status: newclosed
Summary: Mouse clicks limited areaALL: Mouse clicks limited area

comment:5 by digitall, 13 months ago

Component: --Unset--Port: Mac OS X
Note: See TracTickets for help on using tickets.