Opened 5 months ago

Closed 5 months ago

#12477 closed defect (fixed)

AGS: Heroine's Quest steam crash.

Reported by: RetroJaro Owned by: criezy
Priority: normal Component: Engine: AGS
Version: Keywords:
Cc: Game:

Description

Crashes after trying to make a new character.

Attachments (1)

2021-04-22 09_59_41-Greenshot.png (764.2 KB ) - added by RetroJaro 5 months ago.

Download all attachments as: .zip

Change History (4)

by RetroJaro, 5 months ago

comment:1 by sev-, 5 months ago

Summary: Heroine's Quest steam crash.AGS: Heroine's Quest steam crash.

comment:2 by criezy, 5 months ago

Are you on Windows by any chance?
The game works properly for me, but after the character creation it writes a file named heroinesquest-\hqrecord.dat in my save folder. On macOS that works, but I can imagine that on Windows it may not like the \ in the name.

The issue is in our file path mapping code. In this case the script asks the engine to create a file with a path that has two \ (it is $SAVEGAMEDIR$\\hqrecord.dat) and while we correctly strip the first one, the second one is not removed.

comment:3 by criezy, 5 months ago

Owner: set to criezy
Resolution: fixed
Status: newclosed

I pushed a fix for this issue. I think it should now work on Windows as well.

Note: See TracTickets for help on using tickets.