Opened 14 months ago

Closed 10 months ago

Last modified 3 months ago

#12474 closed defect (fixed)

AGS: Text display issues (Maniac Mansion Deluxe)

Reported by: zxtheproto Owned by: dreammaster
Priority: normal Component: Engine: AGS
Version: Keywords:
Cc: Game:

Description

Maniac Mansion Deluxe has some issues with its text in ScummVM, causing alignment issues with the shadow of dialogue text and artifacts on the verb object prompt text.

Original game:
https://i.imgur.com/LUQCCG1.png
https://i.imgur.com/PHcQuvX.png

ScummVM:
https://i.imgur.com/dWqR6rJ.png
https://i.imgur.com/mYSERB0.png

Steps to reproduce:

  1. Start game with any characters.
  1. Finish introduction sequence and see error with dialogue text, most prominent with long strings of text such as seen above. Certain text characters appear blurry, and occasionally pull away from the background shadow.
  1. Start gameplay. Note the blurry text at the verb/object prompt, and the recurring issue of the misaligned text background.

Version tested: Windows x86 build e3d4462b

Change History (3)

comment:1 by scureuil, 13 months ago

The same visual issues are present in the Maniac Mansion Mania fangames series (https://www.maniac-mansion-mania.com/index.php/en/spiele/episoden/staffel-1.html)

comment:2 by dreammaster, 10 months ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

Finally got the font to display correctly. The text drawing routine now detects if it's drawing an outline and uses the standard font the outline is for to calculate character widths when drawing the text. This fixes the problem where some outline characters were actually wider than their source counterparts, and was causing the positioning to get out of sync.

comment:3 by LukasThyWalls, 3 months ago

This bug was reported here https://bugs.scummvm.org/ticket/12972 as i realized it happens in all AGS games without this kind of characters and i found the report. NOT REOPEN HERE.


As in version 2.6.0git4261-g9ebd702a4cf (Mar 12 2022 04:47:50), with Maniac Mansion Deluxe 1.4 ({"MANIAC.EXE", 0, "465f972675db2da6040518221af5b0ba", 10409172}) some translation still has this issue, and others don't.

Spanish version, for example:
https://i.imgur.com/OXuDlCW.png

French, Finnish and others are, meanwhile Italian doesn't.

It seems is related to the special characters used in each language different to the english ones (á, é, í, ó, ú, ä, ç...) and those characters aren't rendered in the outline, so phrases without that kind of characters look normal, and others with them don't.

Also, talking about the verb sentence (and the dialogs itselfs, but they aren't as noticiable as in the verb sentence), you can see the font aren't pixel perfect resized and they look with blurriness (it also happens in the save/load menu https://i.imgur.com/7axfdCI.png).
Those fonts looks like are taked from the SCUMM/Monkey/Indy era, but in Maniac Mansion Deluxe, doesn't look like that at all, including the outline:
https://i.imgur.com/yrD98QA.png

I'm not against using an original kind-of SCUMM font, but at least they could look much better than that, pixel perfect resized.

Thanks in advance!

Last edited 3 months ago by LukasThyWalls (previous) (diff)
Note: See TracTickets for help on using tickets.