Opened 5 months ago

Closed 5 months ago

#12452 closed defect (fixed)

AGS: Unknown variant result in "data not found" when running game

Reported by: dreammaster Owned by: criezy
Priority: normal Component: Engine: AGS
Version: Keywords: has-pull-request
Cc: Game:

Description

The problem can be seen for game variants we don't yet have explicit detection entries for, such as for Tale of Lonkey Island found here: https://www.adventuregamestudio.co.uk/site/games/game/2100-the-tale-of-lonkey-island/

When the game is added, two targets appear: one for Lonkey Island Unknown Variant, and one for the generic AGS game Unknown Variant. If you add the game using the Lonkey Island Unknown Variant, then thereafter, the game won't run.

The problem seems to be in the fallback detection code. When the game is run, the only fallback entry found is the generic "ags" one. But there's code in the base advanced detector that ignores it, since the entry in the config file has a different game Id of "lonkeyisland" than "ags".

Change History (3)

comment:1 by criezy, 5 months ago

This sounds like a regression I would have introduced with https://github.com/scummvm/scummvm/commit/6d2a62fe
Before that change unknown variants could not be added (only the AGS fallback could be added). The change to also allow adding unknown variant was mostly an "bonus" in that commit, and I tested it was working. I probably was lucky with the game I chose for testing.
We can either change back the behaviour (mark the unknown variants as cannot be added as is done in the base class) or try to properly handle starting those unknown variants.

comment:2 by criezy, 5 months ago

Keywords: has-pull-request added

comment:3 by criezy, 5 months ago

Owner: set to criezy
Resolution: fixed
Status: newclosed

It is now possible to run unknown AGS game variants.

Note: See TracTickets for help on using tickets.