Opened 10 months ago

Closed 4 months ago

#12411 closed defect (fixed)

The longest journey: black screen when alt+enter

Reported by: legluondunet Owned by: bluegr
Priority: normal Component: Engine: Stark
Version: Keywords:
Cc: Game: The Longest Journey

Description

Hello,
I just tested "The longest journey" (GOG) in latest ScummVM version (git compiled 11 april 2021).
When you press alt+enter to enter fulsscreen or windw mode, the game is all black, you can hear audio. There is no way to obtain game screen again, you have to quit game.

Terminal log:

Using game controller: X360 Controller
WARNING: SDL mixer output buffer size: 512 differs from desired: 1024!
WARNING: You are missing a valid 'translations.dat' file. GUI translation will not be available!
Using game controller: X360 Controller
User picked target 'tlj-win' (engine ID 'stark', game ID 'tlj')...

Looking for a plugin supporting this target... Stark

INFO: OpenGL Vendor: NVIDIA Corporation
INFO: OpenGL Renderer: GeForce GTX 770/PCIe/SSE2
INFO: OpenGL Version: 4.6.0 NVIDIA 460.39
INFO: OpenGL Red bits: 8
INFO: OpenGL Green bits: 8
INFO: OpenGL Blue bits: 8
INFO: OpenGL Alpha bits: 0
INFO: OpenGL Z buffer depth bits: 24
INFO: OpenGL Double Buffer: 1
INFO: OpenGL Stencil buffer bits: 0
INFO: GLEW Version: 2.1.0
INFO: GLSL version: 4.60 NVIDIA
INFO: OpenGL Vendor: NVIDIA Corporation
INFO: OpenGL Renderer: GeForce GTX 770/PCIe/SSE2
INFO: OpenGL Version: 4.6.0 NVIDIA 460.39
INFO: OpenGL Red bits: 8
INFO: OpenGL Green bits: 8
INFO: OpenGL Blue bits: 8
INFO: OpenGL Alpha bits: 0
INFO: OpenGL Z buffer depth bits: 24
INFO: OpenGL Double Buffer: 1
INFO: OpenGL Stencil buffer bits: 0
INFO: GLEW Version: 2.1.0
INFO: GLSL version: 4.60 NVIDIA

$ ./scummvm --version
ScummVM 2.3.0git15062-g0c3be802d8 (Apr 11 2021 09:30:51)
Features compiled in: TAINTED Vorbis FLAC MP3 ALSA SEQ sndio TiMidity RGB zLib MPEG2 FluidSynth Theora A/52 FreeType2 FriBiDi JPEG PNG GIF cloud (servers, local) TinyGL OpenGL (with shaders) GLEW

Ubuntu 20.04

Change History (7)

comment:1 by legluondunet, 5 months ago

Last edited 5 months ago by legluondunet (previous) (diff)

comment:2 by dianiu, 5 months ago

Same problem with different hardware, in this case an AMD GPU.

Terminal log:

INFO: OpenGL Vendor: ATI Technologies Inc.
INFO: OpenGL Renderer: Radeon RX 580 Series
INFO: OpenGL Version: 4.6.14739 Compatibility Profile Context 21.6.1 27.20.22001.14011
INFO: OpenGL Red bits: 8
INFO: OpenGL Green bits: 8
INFO: OpenGL Blue bits: 8
INFO: OpenGL Alpha bits: 8
INFO: OpenGL Z buffer depth bits: 24
INFO: OpenGL Double Buffer: 1
INFO: OpenGL Stencil buffer bits: 8
INFO: GLEW Version: 2.1.0
INFO: GLSL version: 4.60
INFO: OpenGL Vendor: ATI Technologies Inc.
INFO: OpenGL Renderer: Radeon RX 580 Series
INFO: OpenGL Version: 4.6.14739 Compatibility Profile Context 21.6.1 27.20.22001.14011
INFO: OpenGL Red bits: 8
INFO: OpenGL Green bits: 8
INFO: OpenGL Blue bits: 8
INFO: OpenGL Alpha bits: 8
INFO: OpenGL Z buffer depth bits: 24
INFO: OpenGL Double Buffer: 1
INFO: OpenGL Stencil buffer bits: 8
INFO: GLEW Version: 2.1.0
INFO: GLSL version: 4.60
INFO: OpenGL Vendor: ATI Technologies Inc.
INFO: OpenGL Renderer: Radeon RX 580 Series
INFO: OpenGL Version: 4.6.14739 Compatibility Profile Context 21.6.1 27.20.22001.14011
INFO: OpenGL Red bits: 8
INFO: OpenGL Green bits: 8
INFO: OpenGL Blue bits: 8
INFO: OpenGL Alpha bits: 8
INFO: OpenGL Z buffer depth bits: 24
INFO: OpenGL Double Buffer: 1
INFO: OpenGL Stencil buffer bits: 8
INFO: GLEW Version: 2.1.0
INFO: GLSL version: 4.60
INFO: OpenGL Vendor: ATI Technologies Inc.
INFO: OpenGL Renderer: Radeon RX 580 Series
INFO: OpenGL Version: 4.6.14739 Compatibility Profile Context 21.6.1 27.20.22001.14011
INFO: OpenGL Red bits: 8
INFO: OpenGL Green bits: 8
INFO: OpenGL Blue bits: 8
INFO: OpenGL Alpha bits: 8
INFO: OpenGL Z buffer depth bits: 24
INFO: OpenGL Double Buffer: 1
INFO: OpenGL Stencil buffer bits: 8
INFO: GLEW Version: 2.1.0
INFO: GLSL version: 4.60
INFO: OpenGL Vendor: ATI Technologies Inc.
INFO: OpenGL Renderer: Radeon RX 580 Series
INFO: OpenGL Version: 4.6.14739 Compatibility Profile Context 21.6.1 27.20.22001.14011
INFO: OpenGL Red bits: 8
INFO: OpenGL Green bits: 8
INFO: OpenGL Blue bits: 8
INFO: OpenGL Alpha bits: 8
INFO: OpenGL Z buffer depth bits: 24
INFO: OpenGL Double Buffer: 1
INFO: OpenGL Stencil buffer bits: 8
INFO: GLEW Version: 2.1.0
INFO: GLSL version: 4.60

ScummVM version (windows):

ScummVM 2.3.0git22435-g03186fa79f (Aug 22 2021 04:56:09)
Features compiled in: TAINTED Vorbis FLAC MP3 RGB zLib MPEG2 FluidSynth Theora AAC A/52 FreeType2 FriBiDi JPEG PNG GIF taskbar TTS cloud (servers, local) TinyGL OpenGL (with shaders) GLEW

comment:3 by criezy, 5 months ago

I have the same issue on macOS with a mac M1. I would hazard a guess that this is probably a general issue and not one specific to some hardware or OS.

comment:4 by dianiu, 5 months ago

The problem is changing the window size because the problem also happens if you start in full screen and try to change to window.

comment:5 by antoniou79, 5 months ago

I can confirm I can reproduce this on a recent build from master.
Setting "OpenGL" as the Game 3D Renderer from edit game, results in permanent black screen, when toggling between fullscreen and windowed. It's "permanent" as in, the image does not come back if you return to your original setting (whether fullscreen or windowed).

Also, setting "OpenGL with shaders" as Game 3D Renderer results in segmentation fault (the game crashes), when attempting to toggle between fullscreen and windowed.

comment:6 by Thunderforge, 4 months ago

Reproduced on 2021-09-22 build for Windows x64. The black screen also happens when starting in full screen and pressing alt+enter to go to windowed mode.

comment:7 by bluegr, 4 months ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

The issue should be fixed now with pull request 3392:
https://github.com/scummvm/scummvm/pull/3392
Closing

Note: See TracTickets for help on using tickets.