Opened 3 years ago

Closed 3 months ago

#12402 closed defect (fixed)

AGS: Slowness in some games.

Reported by: cyberdudb Owned by: fracturehill
Priority: normal Component: Engine: AGS
Version: Keywords: Slowness
Cc: Game:

Description

I've noticed some games run slower in Scummvm than using the standalone port (https://github.com/adventuregamestudio/ags)

Limey Lizard: Waste Wizard and The Visitor 3 are such examples of the games that run slower in Scummvm.

Change History (8)

comment:1 by laenion, 3 years ago

The slowness also happens for "The Cat Lady", which seems to run at about 1/3 of its expected speed. A good indicator is the ticking clock in the intro scene (see e.g. https://youtu.be/TVvefhlmC98?t=37), which ticks about every three seconds when playing via ScummVM, while it should take about 1 second as seen in the video.

comment:2 by dreammaster, 2 years ago

Summary: Slowness in some AGS games.AGS: Slowness in some games.

comment:3 by chrisis123, 11 months ago

I have started "The Cat Lady" (GOG version) on ScummVM 2.8.0git (10MAR) and the intro seems to play fine for me (same as in the linked video), didn't notice a slowdown on my PC, so this issue may be resolved

Last edited 11 months ago by chrisis123 (previous) (diff)

comment:4 by Thunderforge, 11 months ago

I assume the previous comment is referring to The Cat Lady. Good to know the clock is now timed properly.

Hopefully someone can check the other games listed. If we don't have clear reproduction steps to demonstrate slowness, this bug should probably be closed (with new ones being created if it's discovered in the future).

comment:5 by criezy, 11 months ago

The performance issues in the AGS engine are known and are related mostly to the colour blending code. The situation has improved since that bug was open, for example with https://github.com/scummvm/scummvm/commit/8f8eebc427297d179978b254ba5b16cef657eb35 and https://github.com/scummvm/scummvm/commit/0a4460ba343fb394f2385559bab90b404140dd25.

But games can still be slow on old hardware, and some of the most demanding games may even be slow on recent hardware. I think we still need to optimize further the sprite blending code by having specialized versions that depend on the color format and would not need a generic decomposition of the colors into RGB components. This needs to be done carefully as the blending routines need to be accurate as some games check the resulting color values, and introducing differences would cause regressions.

comment:6 by laenion, 11 months ago

For me the intro in "The Cat Lady" is still too slow. Not down to one third of the speed as before, but still significantly slower, so I'd assume criezy is correct.

comment:7 by tag2015, 9 months ago

Regarding the other two games mentioned, Limey Lizard is not a heavy game so I suppose the "slowness" was related to the walkcycle bugs that affected some old games.
The Visitor 3 is a bit more intensive, but there are worse offenders.
Anyway, this bugreport should probably stay open at least until the blending optimizations are completed.

comment:8 by tag2015, 3 months ago

Owner: set to fracturehill
Resolution: fixed
Status: newclosed

The optimizations have been completed and fixed, so I guess this report can be closed.

Note: See TracTickets for help on using tickets.