Opened 16 years ago

Closed 15 years ago

#1237 closed defect (fixed)

INDY3: Lockup in Berlin

Reported by: SF/quietust Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 3

Description

ScummVM 0.5.3cvs (Sep 19 2003 16:02:44)

In the 2nd 'room' in Berlin (where Elsa walks in and is
followed by Indy), the entire program locks up after 2
footsteps are played. However, the music continues to
play.
This happens in the PC VGA version as well as the Amiga
(EGA) version (couldn't check with the PC EGA version,
as I don't have a savegame that far into the game).

I have attached savegames for the PC-VGA and Amiga
versions.

Ticket imported from: #809547. Ticket imported from: bugs/1237.

Attachments (2)

indy3ega.s02 (53.8 KB) - added by SF/quietust 16 years ago.
Indy3VGA - immediately before entering Berlin
amiga_indy3ega.s08 (54.2 KB) - added by SF/quietust 16 years ago.
Indy3Amiga - immediately before entering Berlin

Download all attachments as: .zip

Change History (8)

Changed 16 years ago by SF/quietust

Attachment: indy3ega.s02 added

Indy3VGA - immediately before entering Berlin

Changed 16 years ago by SF/quietust

Attachment: amiga_indy3ega.s08 added

Indy3Amiga - immediately before entering Berlin

comment:1 Changed 16 years ago by fingolfin

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:2 Changed 15 years ago by fingolfin

My fix for this issue caused a regression, see bug #1032964

The change looks fishy to me anyway, so I'll see if I can find a better
solution.

comment:3 Changed 15 years ago by fingolfin

Resolution: fixed
Status: closednew

comment:4 Changed 15 years ago by fingolfin

So it turns out this bug here is caused by my "WORKAROUND #2" in
boxes.cpp, for bug #770690 and bug #774783... so let's revise that one,
too
:-)

comment:5 Changed 15 years ago by fingolfin

Resolution: fixed
Status: newclosed

comment:6 Changed 15 years ago by fingolfin

I modified the fix; this bug is still "fixed" by it, but the solution seems
better in so far as it only cures this particular problem instead of doing a
relatively major and (as I strongly believe) incorrect change to the
walking code, which caused bug #1032964 and maybe other regressions.

Note: See TracTickets for help on using tickets.