Opened 2 years ago

Closed 2 years ago

#12335 closed defect (fixed)

AGS: Quest for Glory II Remake: Import a Hero does not work

Reported by: OmerMor Owned by: OmerMor
Priority: normal Component: Engine: AGS
Version: Keywords:
Cc: Game: Quest for Glory 2


Running the latest daily build (2021-03-03 01:44:20 downloaded on 2021-03-19) on Windows 10.

When starting the game, and pressing "Import a Hero" the game writes the following message:
"I'm sorry, there don't appear to be any Quest for Glory saved characters in this folder."

I've tried to put a qfg1 exported save file in the following folders:

  • ScummVM's save path
  • ScummVM's program path
  • The game's folder

None of these worked.

Attachments (2)

qfg1-q1-abra.sav (99 bytes ) - added by OmerMor 2 years ago.
Screenshot 2021-03-20 at 22.17.53.png (365.6 KB ) - added by criezy 2 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 by OmerMor, 2 years ago

Just confirmed that this is still reproduced is the 2021-03-19 daily snapshot as well.

comment:2 by dreammaster, 2 years ago

Could you attach the exported save for testing purposes? Thanks.

by OmerMor, 2 years ago

Attachment: qfg1-q1-abra.sav added

comment:3 by OmerMor, 2 years ago


comment:4 by criezy, 2 years ago

This seems to work for me.

If I put your file in the game folder it is found (see screenshot in attachment).

If I put the file in the save path, I need to add the game target as a prefix (in my case "qfg2agdi-") as in ScummVM we add a prefix for all the files in the save path to avoid conflicts between several AGS games (for example several games try to create or read a 'user.cfg' file in the save path).

comment:5 by dreammaster, 2 years ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

comment:6 by OmerMor, 2 years ago

Resolution: fixed
Status: closednew

On my machine it doesn't work. Maybe it's a problem with the Windows build?
I have the file in my game folder, as well as in my save path.
I have it named both as qfg1-q1-abra.sav and qfg2agdi-q1-abra.sav
I still get the same "not found" reply.
I monitored ScummVM's file system access with Sysinternals' Process Monitor and saw that it does indeed scan the relevant folders and even find the save files.
However an operation of IRP_MJ_CREATE for the file returns result of NAME_INVALID.

Version 0, edited 2 years ago by OmerMor (next)

comment:7 by dreammaster, 2 years ago

Well, I confirmed that the fix I did yesterday worked when I did Downloaded all the attachments as a zip, and then extracted the .sav file. The way it works, it should list any .sav file in your game directory, and any .sav file in the ScummVM save path that has a "qfg2agdi-*.sav" form (or whatever prefix/target your game entry has).

comment:8 by dreammaster, 2 years ago

Resolution: fixed
Status: newpending

comment:9 by OmerMor, 2 years ago

Owner: changed from dreammaster to OmerMor
Status: pendingclosed

Thanks! Verified fix in the latest daily snapshot.

Note: See TracTickets for help on using tickets.