Opened 8 weeks ago

Closed 7 weeks ago

#12328 closed defect (fixed)

AGS: The Shivah Enhanced: Some GUI elements are misaligned

Reported by: Tea23 Owned by: criezy
Priority: normal Component: Engine: AGS
Version: Keywords:
Cc: Game:

Description

Screenshots attached. The Yiddish dictionary and the achievements dialogue have incorrect dimensions. In the latter case this causes the description text to overflow.

Content-wise there is nothing missing from the dictionary.

Attachments (2)

scummvm-shivah-00002.png (142.4 KB ) - added by Tea23 8 weeks ago.
scummvm-shivah-00000.png (86.8 KB ) - added by Tea23 8 weeks ago.

Download all attachments as: .zip

Change History (4)

by Tea23, 8 weeks ago

Attachment: scummvm-shivah-00002.png added

by Tea23, 8 weeks ago

Attachment: scummvm-shivah-00000.png added

comment:1 by Tea23, 8 weeks ago

Component: --Unset--Engine: AGS

comment:2 by criezy, 7 weeks ago

Owner: set to criezy
Resolution: fixed
Status: newclosed

There was an incorrect computation of the line spacing when displaying multiple lines of text with a TTF font in ScummVM. This is fixed in 12829b2 and I have verified that now the Yiddish dictionary is displayed as in the original.

Hopefully the achievement issue was caused by the same bug and is fixed as well.

Note: See TracTickets for help on using tickets.