Opened 19 months ago

Closed 9 months ago

Last modified 8 months ago

#12305 closed defect (outdated)

STARK: RPI: Engine GL Error prevents game from running on Raspberry Pi 3b

Reported by: rodgerdavidson Owned by: digitall
Priority: normal Component: Engine: Stark
Version: Keywords: stark, tlj, longest journey, pi, raspberry pi, 3b, retropie
Cc: rodgerdavidson Game: The Longest Journey

Description

I am testing a recent DEV build of ScummVM through RetroPie on my Raspberry Pi 3b.

I am able to add the game through the GUI. It is not recognized by default, but provides a list of choices in which Longest Journey is one. When I try to execute it, the game crashes immediately without anything being displayed on screen and exits ScummVM back to the RetroPie menu. This occurs when I run from RetroPie or try through the ScummVM GUI.

My copy of The Longest Journey is the original 4 CD release.

RunCommand Log:

Parameters:
Executing: bash /home/pi/RetroPie/roms/scummvm/+Start\ ScummVM.sh "tlj-win"
Using game controller: PS4 Controller
Virtual keyboard pack 'vkeybd_default' loaded successfully
WARNING: Could not get GLSL version!
Could not compile shader box.vertex: !
User picked target 'tlj-win' (engine ID 'stark', game ID 'tlj')...
   Looking for a plugin supporting this target... Stark
Debugger started, type 'exit' to return to the game.
Type 'help' to see a little list of commands and variables.
ERROR: Could not compile shader box.vertex: !
/home/pi/RetroPie/roms/scummvm/+Start ScummVM.sh: line 4: 30432 Segmentation fault      /opt/retropie/emulators/scummvm/bin/scummvm --fullscreen --joystick=0 --extrapath="/opt/retropie/emulators/scummvm/extra" $game

OS Version:

Raspbian GNU/Linux 10 (buster)

ScummVM Version:

ScummVM 2.3.0git (Mar 10 2021 16:28:05)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ sndio TiMidity RGB zLib MPEG2 FluidSynth Theora AAC FreeType2 JPEG PNG virtual keyboard cloud (servers) TinyGL OpenGL OpenGL ES 2

RetroPie Build:

commit c71ddc7288f6be6a545e860200e419d60d38802b (HEAD -> master, origin/master, origin/HEAD)
Author: Jools Wills <buzz@exotica.org.uk>
Date:   Tue Jan 26 03:15:29 2021 +0000

Let me know if I can help provide more info or test a fix.

Thanks!

Change History (8)

comment:1 by rodgerdavidson, 19 months ago

I'm convinced that Longest Journey worked (or at least ran) on an earlier version of Retropie with ResidualVM on the model 3b. However, when I force it to build 0.3.1 or 0.3.0, I am unsuccessful in running it.

I even went so far as to try two prior RetroPie images from scratch, but I cannot find a way install a compiled binary that may have been available at the time. As such, I also had to try building the 0.3.1 and 0.3.0 branches and had no more success on the older OS.

It's worth noting that Longest Journey works perfectly in ResidualVM 0.4.0git on the Raspberry Pi 4 8gb through RetroPie, so the issue seems limited to the model 3b.

Last edited 19 months ago by rodgerdavidson (previous) (diff)

comment:2 by sev-, 19 months ago

Priority: highnormal
Summary: Stark Engine GL Error prevents game from running on Rapberry Pi 3bSTARK: RPI: Engine GL Error prevents game from running on Rapberry Pi 3b

comment:3 by Gemba, 18 months ago

FWIW, it is related how RetroPie is setup on a Rpi3.

See below for a solution and discussion:
https://retropie.org.uk/forum/topic/30107/building-latest-scummvm-with-the-longest-journey-playable

@rodgerdavidson: Feel free to test and report back there.

comment:4 by aquadran, 10 months ago

try daily builds

comment:5 by digitall, 9 months ago

Summary: STARK: RPI: Engine GL Error prevents game from running on Rapberry Pi 3bSTARK: RPI: Engine GL Error prevents game from running on Raspberry Pi 3b

comment:6 by digitall, 9 months ago

Looking at this ticket, it appears that this issue affects only the Retropie build of ScummVM and is very likely to be related to OpenGL setup on the RPi which is out of scope and not a bug in STARK.

Since the original bug submitter did not respond in the last 9 months regarding testing, I think this should be closed as outdated. It can be re-opened if this issue can be replicated in the latest daily build by bug submitter.

comment:7 by digitall, 9 months ago

Owner: set to digitall
Resolution: outdated
Status: newclosed

comment:8 by rodgerdavidson, 8 months ago

Just updating. Current release build of ScummVm for retropie on Rpi3 seems to be working well. I was able to boot and play the prologue. Not sure what was changed, but nice work team!

Note: See TracTickets for help on using tickets.