Opened 4 months ago

Closed 8 days ago

#12259 closed defect (fixed)

SCUMM: Loom (EGA) - Path finding issues for Bobbin at Dragon's lair

Reported by: antoniou79 Owned by: athrxx
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Loom

Description

I am labelling as a potential path-finding issue, but it could be something else, and it also could be an original engine bug (I haven't checked).

I am testing with a development build (2.3.0git) on Windows 10.

Basically, Bobbin can be moved to a few spots, on the left or right of the dragon and, from there, double-clicking on the "dragon" or the "gold" won't result in Bobbin moving closer and "focusing" on those things (which would mean that the respective "label" would appear under the thumbnail on the bottom right and Bobbin would be able to cast a spell).

The "workaround" is to move Bobbin first somewhere else, and then double click on "dragon" or "gold", but this should not be required normally, and it could be confusing for a new player.

I am providing a saved game, with Bobbin at such a spot.

Attachments (1)

loom-ega.s38 (16.4 KB ) - added by antoniou79 4 months ago.

Download all attachments as: .zip

Change History (4)

by antoniou79, 4 months ago

Attachment: loom-ega.s38 added

comment:1 by athrxx, 9 days ago

I wonder if this a valid ticket or not. Could you please, whenever you find the time, check if the issue persists? I remember that we talked about this, but I can't seem to notice any problems just now. Some changes have been made since then (although not in relation to this bug ticket). So maybe it even got fixed "accidently"... ;-)

in reply to:  1 comment:2 by antoniou79, 9 days ago

Replying to athrxx:

I wonder if this a valid ticket or not. Could you please, whenever you find the time, check if the issue persists? I remember that we talked about this, but I can't seem to notice any problems just now. Some changes have been made since then (although not in relation to this bug ticket). So maybe it even got fixed "accidently"... ;-)

I think you are right.

Loading up my attached save it seems that from the saved position for Bobbin the bug still exists. However, if I then move Bobbin around I can't seem to get him to stand at a problematic spot any more. So something fixed the bug, or it wasn't a bug and it was some awry config from my side which no longer exists.

So probably you can go ahead and close the ticket.

comment:3 by athrxx, 8 days ago

Owner: set to athrxx
Resolution: fixed
Status: newclosed

Thanks for confirming. That was my impression, too.
I am quite sure that I could reproduce the issue when you opened the ticket.
But now, when I load my usual dragon's lair savegame Bobbin's walking seems to be fine.
Closing this...

Note: See TracTickets for help on using tickets.