Opened 17 years ago

Closed 17 years ago

Last modified 23 months ago

#1225 closed defect (wontfix)

INDY3/LOOM AMIGA: Music is inaccurate

Reported by: SF/logicdeluxe Owned by:
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 3

Description

ScummVM 0.5.3cvs (Sep 13 2003 11:47:03) Very noticable at the Loom title and with the Indy3 Venice music for instance. The notes aren't played exactly in time. This affects the Amiga versions of Loom and Indy3. Using Windows.

Ticket imported from: #805597. Ticket imported from: bugs/1225.

Change History (5)

comment:1 by Kirben, 17 years ago

Summary: Amiga music is inaccurateINDY3/LOOM AMIGA: Music is inaccurate

comment:2 by fingolfin, 17 years ago

And we never claimed that it was accurate - it's very much work in progress. I'd vote for closing this item.

comment:3 by SF/quietust, 17 years ago

Agreed - it's better than nothing at all, and getting it to play smoothly will require a significant amount of work (namely, writing a MOD player). The problem is that the music player needs a 60Hz timer, and there is no easy way to get one (SDL's timer resolution is only 10ms, and it isn't synchronized very frequently).

comment:4 by fingolfin, 17 years ago

Resolution: wontfix
Status: newclosed

comment:5 by digitall, 23 months ago

Component: --Unset--Engine: SCUMM
Game: Indiana Jones 3
Note: See TracTickets for help on using tickets.