Opened 4 months ago

Closed 2 months ago

#12172 closed defect (invalid)

Quest for Glory 2 AGDInteractive won't start.

Reported by: RetroJaro Owned by: dreammaster
Priority: normal Component: Engine: AGS
Version: Keywords:
Cc: Game:

Description

[2021-02-19 03:29:47] ScummVM 2.3.0git12803-gd855b6db3f (Feb 19 2021 05:32:34)
[2021-02-19 03:29:47] TAINTED Vorbis FLAC MP3 RGB zLib MPEG2 FluidSynth Theora AAC A/52 FreeType2 JPEG PNG cloud (servers, local) TinyGL OpenGL (with shaders) GLEW
[2021-02-19 03:29:47] --- Log opened.
[2021-02-19 03:31:17] Initializing allegro
[2021-02-19 03:31:17] Initializing game data
[2021-02-19 03:31:17] WARNING: TODO: SetCurrentDirectory: ./!
[2021-02-19 03:31:17] Opened game data file: game28.dta
[2021-02-19 03:31:17] Game data version: 42
[2021-02-19 03:31:17] Compiled with: 3.2.0
[2021-02-19 03:31:17] Setting up game configuration
[2021-02-19 03:31:17] Data directory: ./
[2021-02-19 03:31:17] WARNING: File::open: 'E:\Jared files\Games\scummvm\games\#WIP GAMES#\AGS Engine\Quest for Glory II Remake\speech.vox' does not exist!
[2021-02-19 03:31:17] audio.vox found and initialized.
[2021-02-19 03:31:17] Setting up window
[2021-02-19 03:31:17] Initializing TTF renderer
[2021-02-19 03:31:17] Initializing keyboard
[2021-02-19 03:31:17] Initializing mouse: number of buttons reported is 0
[2021-02-19 03:31:17] Install timer
[2021-02-19 03:31:17] Install exit handler
[2021-02-19 03:31:17] Initialize legacy path finder library
[2021-02-19 03:31:17] Game GUI version: 115
[2021-02-19 03:31:18] Game title: 'Quest for Glory II'
[2021-02-19 03:31:18] Checking for disk space
[2021-02-19 03:31:18] Game native resolution: 320 x 200 (32 bit)
[2021-02-19 03:31:18] Graphic settings: driver: Software, windowed: no, screen def: max, screen size: 0 x 0, match device ratio: yes, game scale: proportional
[2021-02-19 03:31:18] Requested graphics driver 'Software' not found, will try existing drivers instead
[2021-02-19 03:31:18] Mouse control: off, base: 1.000000, speed: 1.000000
[2021-02-19 03:31:18] WARNING: TODO: video_on_gfxmode_changed!
[2021-02-19 03:31:18] Initialize sprites
[2021-02-19 03:31:19] * ENGINE HAS SHUTDOWN
[2021-02-19 03:31:19] --- Log closed successfully.

Change History (4)

comment:1 by criezy, 4 months ago

I just tried it, and it starts fine for me.
Here is the end of my log, and we can indeed see that it goes further than yours:

Game GUI version: 115
Game title: 'Quest for Glory II'
Checking for disk space
Game native resolution: 320 x 200 (32 bit)
Graphic settings: driver: Software, windowed: no, screen def: max, screen size: 0 x 0, match device ratio: yes, game scale: proportional
Requested graphics driver 'Software' not found, will try existing drivers instead
Mouse control: off, base: 1.000000, speed: 1.000000
WARNING: TODO: video_on_gfxmode_changed!
Initialize sprites
Engine initialization complete
Starting game
WARNING: channel 2 - same clip assigned
WARNING: File::open: '<path_redacted>/Quest for Glory II/Qfg2vga.010' does not exist!
WARNING: File::open: '<path_redacted>/Quest for Glory II/Qfg2vga.011' does not exist!

comment:2 by RetroJaro, 4 months ago

[2021-02-22 06:15:37] ScummVM 2.3.0git12876-gde8307bd83 (Feb 22 2021 06:27:43)
[2021-02-22 06:15:37] TAINTED Vorbis FLAC MP3 RGB zLib MPEG2 FluidSynth Theora AAC A/52 FreeType2 JPEG PNG cloud (servers, local) TinyGL OpenGL (with shaders) GLEW
[2021-02-22 06:15:37] --- Log opened.
[2021-02-22 06:15:52] Initializing allegro
[2021-02-22 06:15:52] Initializing game data
[2021-02-22 06:15:52] WARNING: TODO: SetCurrentDirectory: ./!
[2021-02-22 06:15:52] Opened game data file: game28.dta
[2021-02-22 06:15:52] Game data version: 42
[2021-02-22 06:15:52] Compiled with: 3.2.0
[2021-02-22 06:15:52] Setting up game configuration
[2021-02-22 06:15:52] Data directory: ./
[2021-02-22 06:15:52] WARNING: File::open: 'E:\Jared files\Games\scummvm\games\#WIP GAMES#\AGS Engine\Quest for Glory II Remake\speech.vox' does not exist!
[2021-02-22 06:15:52] audio.vox found and initialized.
[2021-02-22 06:15:52] Setting up window
[2021-02-22 06:15:52] Initializing TTF renderer
[2021-02-22 06:15:52] Initializing keyboard
[2021-02-22 06:15:52] Initializing mouse: number of buttons reported is 0
[2021-02-22 06:15:52] Install timer
[2021-02-22 06:15:52] Install exit handler
[2021-02-22 06:15:52] Initialize legacy path finder library
[2021-02-22 06:15:52] Game GUI version: 115
[2021-02-22 06:15:52] Game title: 'Quest for Glory II'
[2021-02-22 06:15:52] Checking for disk space
[2021-02-22 06:15:52] Game native resolution: 320 x 200 (32 bit)
[2021-02-22 06:15:52] Graphic settings: driver: Software, windowed: no, screen def: max, screen size: 0 x 0, match device ratio: yes, game scale: proportional
[2021-02-22 06:15:52] Requested graphics driver 'Software' not found, will try existing drivers instead
[2021-02-22 06:15:52] Mouse control: off, base: 1.000000, speed: 1.000000
[2021-02-22 06:15:52] WARNING: TODO: video_on_gfxmode_changed!
[2021-02-22 06:15:52] Initialize sprites
[2021-02-22 06:15:53] * ENGINE HAS SHUTDOWN
[2021-02-22 06:15:53] --- Log closed successfully.

Still does it.

comment:3 by criezy, 3 months ago

RetroJaro, could you try again?
We have fixed a number of issues in the past few weeks, and maybe we fixed the one you were encountering.

If it still doesn't work, please indicate which platform you are trying it on, as it maybe a bug specific to Windows or Linux for example (since I could not reproduce it on macOS).

comment:4 by dreammaster, 2 months ago

Owner: set to dreammaster
Resolution: invalid
Status: newclosed

Can't replicate the problem either, and there's been no further reply. Marking this as closed invalid.

Note: See TracTickets for help on using tickets.