Opened 17 years ago

Closed 17 years ago

#1216 closed defect (invalid)

MI1: Crash at the beginning of Part 2

Reported by: SF/knurek Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

As stated above, the game crashes at the very beginning of the second part. ScummVM just goes to the debugger and displays a message "Gdi::decompressBitmap: default case 73". I'm using an English Floppy version with the latest CVS Win32 build of ScummVM. Just load the attached savestate and check for yourself...

Ticket imported from: #802399. Ticket imported from: bugs/1216.

Attachments (1)

monkeyvga.s01 (43.5 KB ) - added by SF/knurek 17 years ago.

Download all attachments as: .zip

Change History (4)

by SF/knurek, 17 years ago

Attachment: monkeyvga.s01 added

comment:1 by eriktorbjorn, 17 years ago

I can't reproduce this problem with the latest CVS version. I loaded the savegame, waited for the scene to end and walked around the ship for a while with no problems at all.

Maybe the bug was fixed very recently, or maybe your data files have somehow become corrupted?

comment:2 by SF/knurek, 17 years ago

Okay, I've DLed a new version, works fine now... Funny thing, the files are arranged quite different way then in my previous version - it had disk01 up to disk08 (every file about 500 kB), the new one is disk01 to disk04 (every file about 1.0 MB).

comment:3 by Kirben, 17 years ago

Owner: set to Kirben
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.