Opened 16 years ago

Closed 16 years ago

Last modified 13 months ago

#1210 closed defect (worksforme)

ALL: mouse lag in full screen mode regression

Reported by: SF/logicdeluxe Owned by: fingolfin
Priority: normal Component: GUI
Keywords: Cc:
Game:

Description

ScummVM 0.5.3cvs (Sep 2 2003 18:46:56)
This is the more noticable the lower the speed of the
graphics output is and the higher the mouse rate is.
To reproduce it, it is very noticable in the GUI when
scrolling the savegame list for example.
I am using Windows on an AMD K6 450 Mhz.
You may try it in a worse case scenario in order to
make it very obvious since this is probably not a
problem on fast machines, ie setting the mouse rate to
200 Hz (a tool for PS/2-mice under Win9x can be found
here http://www.students.tut.fi/~zibbo/other/ ), select
advmame3x and aspect-ratio-correction, and if you have
a really fast PC you could disable the CPU cache as
well. That way the lag goes to several seconds for me
even in Maniac Mansion, and even in scenes where
nothing is animated except the cursor.
This lag appeared between ScummVM 0.5.3cvs (Aug 31 2003
01:47:28) and ScummVM 0.5.3cvs (Aug 31 2003 22:24:07)
This does not happen at all in windowed mode.

Ticket imported from: #799302. Ticket imported from: bugs/1210.

Change History (5)

comment:1 by eriktorbjorn, 16 years ago

I didn't notice any lagging on my 450 MHz PIII under Linux.
Perhaps it's an SDL problem?

Though I didn't do anything to change the mouse rate. If
that indicates how often mouse movement events will be
generated, then I assume it could make a difference since
they cause ScummVM to redraw the mouse cursor, but surely
that'd be just as noticeable in windowed mode?

comment:2 by fingolfin, 16 years ago

I can't reproduce this on Mac OS X either (using SDL of course).

comment:3 by fingolfin, 16 years ago

This is not a bug as such, if at all it's a performance issue. Would
have to run a profiler to see why your system doesn't manage to
refresh the screen often enough.

comment:4 by fingolfin, 16 years ago

Owner: set to fingolfin
Resolution: worksforme
Status: newclosed

comment:5 by digitall, 13 months ago

Component: --Unset--GUI
Note: See TracTickets for help on using tickets.