#12097 closed defect (fixed)

Entrance to Recall Pad in upper catacombs unreachable

Reported by: frensfrens Owned by: mduggan
Priority: normal Component: Engine: Ultima
Version: Keywords: recall u8
Cc: Game: Ultima VIII: Pagan

Description

Gameversion is GOG English.
Location: upper catacombs
Problem: After using the skull of quakes on the glowing red spot, the floor collapses as intended, but going through the door causes the avatar to fall into a kind of pit. I am not sure how it's supposed to look, since I merely read about this place, but it supposedly contains a teleport location.

First console message after dropping through the floor was:
WARNING: Warning: moving avatar below Z=0. (15909,5821,-2)!

I'll attach the savegame (pre skull-use).

Attachments (1)

ultima8.001 (178.9 KB ) - added by frensfrens 19 months ago.

Download all attachments as: .zip

Change History (4)

by frensfrens, 19 months ago

Attachment: ultima8.001 added

in reply to:  description comment:1 by frensfrens, 19 months ago

Replying to frensfrens:
I forgot to add that I'm on scummvm 2.2.0 (Sep. 14 2020)

comment:2 by mduggan, 18 months ago

Thanks for attaching the savegame. The correct behavior is to have a teleport as soon as you go through the door - there is only a little bit of floor in there.

I tried a few times and sometimes the teleport was triggered correctly, but more often it wasn't - call it 80% reproducible.

There is an egg just inside the door which is supposed to trigger the teleport (you can see it if you turn on editor items with the E key). I will try tracing a bit and see why it's not triggering.

*Edit*
Actually the problem seems to be that the egg is hatching early, but not teleporting as a result - when the problem happens you can click on the egg and see it has hatched=1 in its description on the debug console, but when it works fine you can see it's hatched=0. You can reset the hatched state by walking a bit away from the area and coming back. I suspect it might be related to the bit of missing floor tile in front of the egg. I'll try patching that up and see if it fixes the problem.

Last edited 18 months ago by mduggan (previous) (diff)

comment:3 by mduggan, 18 months ago

Owner: set to mduggan
Resolution: fixed
Status: newclosed

Committed a fix to the missing map tile that *mostly* fixes this. It's still not perfect (there is still a small hole in the floor) but I wasn't able to trigger the bug any more.

Map fixes only get applied on teleporting into the map though, so it needs you to leave the catacombs and come back unfortunately. Ironically this is easier after activating the recall pad, which is what's inside the door.

Note: See TracTickets for help on using tickets.