#12096 closed defect (fixed)

KYRA: LOL: Bug while using Valean Cube

Reported by: keumar76 Owned by: keumar76
Priority: normal Component: Engine: Kyra
Version: Keywords:
Cc: Game: Lands of Lore

Description (last modified by keumar76)

Upper opinwood: when using the valean cube to dispel scotia's barrier, nothing happens. It should turn white but stays black. From what I know it's also supposed to be used right in front of it but when first trying, it said that I'm to close to cast a spell. Now it doesn't say so anymore but still nothing happened, it will only cast while being one step back but still stays black so it won't open.

I'm using scummvm 2.0

Change History (6)

comment:1 by keumar76, 20 months ago

Description: modified (diff)
Priority: normalblocker

comment:2 by digitall, 20 months ago

Component: --Unset--Engine: Kyra
Keywords: lol scotia barrier valean cube removed
Priority: blockernormal

There is relevant information from athrxx here:
https://forums.scummvm.org/viewtopic.php?f=2&t=16196

"I have just done a quick test with LOL CD, LOL Floppy English and LOL PC-98 Japanese. The Vaelan's Cube works fine for me in all 3 versions. You have to pick it up and right click with it on one of the character portraits. You have to do it three times I think. After the first click there is an animation on Scotia's barrier, but it will not break. The cube will change color. After the second click I only get a comment from the character saying that they have to remove the barrier. And after the third right click there is another animation on the barrier and it will be removed.

Equipping the Vaelan's Cube as a weapon would only work on early floppy versions and only if you do not apply the official Westwood patch (ftp://ftp.westwood.com/pub/lands1/updates/lolus123.exe). Using the cube in this manner causes glitches (like being able to dupilcate the Vaelan's Cube indefinitely at the barrier). That's why I have fixed this in ScummVM so you never get to equip the cube like that regardless of whether you have applied the patch or not.

So, if there is actually any issue at all, maybe it's something with the right mouse clicks in general? Are you able to use other items by right clicking on the character portraits?

I you do want to open a bug tracker ticket, please attach a savegame from before Scotia's barrier."

comment:3 by digitall, 20 months ago

Summary: lands of lore/ the throne of Chaos bug while using Valean cubeKYRA: LOL: Bug while using Valean Cube

comment:4 by digitall, 20 months ago

@keumar76: Could you attach a savegame as requested by athrxx? This will help the KYRA engine developers replicate and track down the issue.

It would also be helpful if you could try an earlier version of ScummVM i.e. 1.8.0 as I suggested on the forum to see whether this is a recent regression.

Apart from this, it would useful to tell us exactly what operating system / platform you are using? ie.
https://docs.scummvm.org/en/latest/help/report_bugs.html

comment:5 by digitall, 20 months ago

@keumar76: It would also be good to see if you can replicate this issue with the latest stable release i.e. v2.2.0 as v2.0 is slightly older:
https://www.scummvm.org/downloads/#current

If you can, then can you try with the latest daily build from:
https://www.scummvm.org/downloads/#daily

This bug may have been fixed since v2.0 so best to check...

comment:6 by keumar76, 20 months ago

Owner: set to keumar76
Resolution: fixed
Status: newclosed

Sorry guys for the waste of time and missing info.

Indeed, I tried with the v2.2.0 and problem solved. Thanks a lot!

Note: See TracTickets for help on using tickets.