Opened 6 weeks ago

Closed 4 weeks ago

Last modified 4 weeks ago

#12088 closed defect (fixed)

Ultima VIII - Lose all items when guards bring you to Devon

Reported by: bliznik Owned by: bliznik
Priority: high Component: Engine: Ultima
Version: Keywords: Ultima VIII Devon items trapped wall
Cc: Game: Ultima VIII: Pagan

Description

In Ultima VIII, there is a portion of the game where you use a scroll to open a wall and read a book. After you read this book, the guards take you to Devon/Mordea, where you can denounce Mordea as the true heir and initiate a fight between Devon and Mordea.

Unfortunately, when the guards take you, all your items and armor drops to the ground. The wall also returns back to its original configuration, and all of your items are now trapped in that location.

Please fix this to prevent all of your items from dropping when the guards take you.

This is using the "daily build" of 1/26/2021.

Attachments (1)

Screenshot_1.jpg (237.5 KB ) - added by bliznik 6 weeks ago.

Download all attachments as: .zip

Change History (7)

by bliznik, 6 weeks ago

Attachment: Screenshot_1.jpg added

comment:1 by bliznik, 6 weeks ago

I also just tried a bit of a workaround, where I use the scroll to open the wall, then I hide the scroll in a basket, then I enter the room to read the book and get taken to Devon. After the cutscene, I run back to use the scroll in the basket in an attempt to retrieve my items. But the game then crashes after that.

comment:2 by bliznik, 5 weeks ago

Component: Port: Win64Engine: Ultima
Version: gsoc

comment:3 by mduggan, 4 weeks ago

Do you have a savegame handy before the event? All the items dropping like this seems to be caused by a savegame bug. I haven't been able to reproduce it reliably so I haven't debugged it fully. It seems to get triggered/resolved if you leave the map and go back to it. Your items may still drop once but in a place where you can get them back.

comment:4 by bliznik, 4 weeks ago

I just started a new game with the latest build, loaded my savegame where I previously would lose items after triggering the event, and did not lose any of my items after triggering the event.

I would consider this issue solved. It seems like whatever changed between when I opened this issue and now has resolved this issue.

Thanks for looking into it!

comment:5 by bliznik, 4 weeks ago

Owner: set to bliznik
Resolution: fixed
Status: newclosed

comment:6 by mduggan, 4 weeks ago

Thanks for the update. Feel free to reopen if you see it again.

Note: See TracTickets for help on using tickets.