Opened 21 months ago

Closed 13 months ago

Last modified 13 months ago

#12081 closed defect (fixed)

TOON: Toonstruck Demo doesn't start with script error

Reported by: SupSuper Owned by: SupSuper
Priority: high Component: Engine: Toon
Version: Keywords:
Cc: Game: Toonstruck

Description

There's detection entries for the Demo version but the game fails to start with the message "ERROR: Couldn't open script file _START01.EMC".

Demo can be found on archive.org: https://archive.org/search.php?query=toonstruck%20demo

Tested with ScummVM 2.2.0 and latest build.

Change History (7)

comment:1 by sev-, 14 months ago

Priority: normalhigh

This would be nice to get fixed before the release.

comment:2 by NMIError, 13 months ago

Owner: set to SupSuper
Resolution: fixed
Status: newclosed

I just pushed a few fixes for the Toonstruck demo. I don't think it was really supported after all; it would crash on a missing movie file and missing main menu. It now runs, but it is unstable. I'm not sure if that's specific to the demo or the Toonstruck engine in general.

Your specific issue is probably caused by not installing the demo. There is a ZIP file in the MISC directory with some critical files which are unpacked by the installer. Could you check if those files are present in your game folder and retest with a new build?

comment:3 by SupSuper, 13 months ago

It does start now, but crashes soon into the game. It should probably be flagged as ADGF_UNSTABLE.

I suspect whoever worked on this engine thought the German demo and English demo were the same, but they are very different. For example the German demo has a main menu, which your fixes now removed.

comment:4 by NMIError, 13 months ago

I assumed the same thing... I will take a look at the German demo. Thanks for the info.

comment:5 by NMIError, 13 months ago

I've marked the English demo as unstable; there seem to be several data structure differences compared to the other versions of the game which require more thorough investigation.

I've started the German demo from the ScummVM website in DOSBox and it does not have a main menu. After playing the logo movie it starts directly in the game, just like the English demo. Do you have a different version of the German demo with a main menu?

comment:6 by SupSuper, 13 months ago

Huh, you're right. I was comparing it to the behavior in ScummVM 2.2.0, where the German demo showed a main menu (presumably because it has a _START01.EMC), but in DOSBox it does not show up. So I guess that too was a bug.

comment:7 by NMIError, 13 months ago

Well, at least that bug is fixed now. It will take more effort to support the English demo, so I opened a separate issue for that.

Note: See TracTickets for help on using tickets.