Opened 18 months ago

Closed 5 months ago

#12077 closed defect (fixed)

PETKA: Very short animation

Reported by: Tkachov Owned by: whiterandrek
Priority: low Component: Engine: Petka
Version: Keywords: short animation, loading lag, screens switch
Cc: Game: Petka 2

Description

This happens once in Red Comrades 2. I think the reason might be the lag that happens when the screen loads (I also think that's the reason in #12075)

Video demonstration: https://youtu.be/g9U0_JPNdYI (first 8 seconds are in the original game, the rest is in ScummVM).

In the original game we're shown how the gates are being deactivated. I record videos in 60 FPS and this animation takes 66 frames. In ScummVM a long screen loading happens (you can hear the background sound, but you won't see the screen itself) and then you would only see the end of that animation for 20 frames.

I think ScummVM should either "pause" while loading screens, so animation/sound would start after it is loaded, or load screens as fast as the original game.

Attachments:

attachment:petka2.s06 ScummVM save file on the shown screen
attachment:save8.dat Original game save file

ScummVM 2.3.0git11899-g3fb4d67b4e (Jan 16 2021 05:21:57)
Windows 10 version 20H2 64-bit
Red Comrades 2 (petka2)

To reproduce:

  • load the save;
  • put the lava or the soil on the corresponding stand;
  • <you would see the cutscene, and in ScummVM the other screen would show up for a very short time>.

Attachments (2)

petka2.s06 (29.6 KB ) - added by Tkachov 18 months ago.
save8.dat (56.9 KB ) - added by Tkachov 18 months ago.

Download all attachments as: .zip

Change History (5)

by Tkachov, 18 months ago

Attachment: petka2.s06 added

by Tkachov, 18 months ago

Attachment: save8.dat added

comment:1 by Tkachov, 18 months ago

If you unpack .str archives into the game folder, the screen loads as fast as in the original game, so this animation shows up alright.

comment:2 by whiterandrek, 17 months ago

It’s strange that unpacking helps.

Probably this happens because I have removed prealoading resources in most places

comment:3 by whiterandrek, 5 months ago

Owner: set to whiterandrek
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.