#12037 closed defect (fixed)

TWINE: No music in FLA movie

Reported by: vvs- Owned by: vvs-
Priority: normal Component: Engine: TwinE
Version: Keywords:
Cc: Game: Little Big Adventure

Description

There is no CD music in Twinsen's dream video. But I have music in main menu. All CD audio tracks are there as track[1-9].flac.

Also, I've noticed that there is no sound of surf in the title video, where Twinsen is flying through game title.

Change History (23)

comment:1 by mgerhardy, 21 months ago

The intro should be fixed in 53d6af71bd4e08c2cb7412751c05f800031f249c

comment:2 by sev-, 21 months ago

Owner: set to mgerhardy
Resolution: fixed
Status: newclosed

comment:3 by sev-, 21 months ago

Summary: No music in FLA movieTWINE: No music in FLA movie

comment:4 by vvs-, 21 months ago

Resolution: fixed
Status: closednew

The sounds are now fixed, but there is still no music.

BTW, the music seems to be not CD audio after all, but probably MIDI.

comment:5 by mgerhardy, 21 months ago

Yes, the original game played midi during cutscenes - most likely due to not trying to read the cinematic and the music from the cd at the same time.

You can find a list with midi files here: https://forum.magicball.net/showpost.php?p=361476&postcount=1

Which one should get played in the cutscenes?

comment:6 by vvs-, 21 months ago

Are you suggesting that they are hardcoded? I'd expect the midi track number to be stored inside FLA file itself.

In any case it's very difficult to compare midi tracks. The very nature of midi makes the actual sound depend on the instrument samples which you have, so they will sound quite differently using different samples. Also, many tracks in LBA actually sound very similar, if not identical.

I can (vaguely) identify the track in INTROD.FLA as number lbaI2 in midi files. But that midi track is actually much longer than the video. Also, I can't say anything about other videos without playing all the game which is impractical ATM.

comment:7 by mgerhardy, 21 months ago

That already helps - there are still a few unknown values in the fla header. Having at least an idea of the possible values might help to identify them.

Then there is entry 24 in ress.hqr which should contain fla information - but nothing is known yet about that entry afaik.

comment:9 by mgerhardy, 21 months ago

I've pushed a potential fix - but I need your feedback. Can't get midi running in dosbox - so it's impossible for me to verify on my own. I've tested the introd scene and the baffe scene when twinsen is imprisoned again in the asylum.

comment:10 by mgerhardy, 21 months ago

oh, if anyone is testing this with a cutscene that is played while a scene is active, please keep in mind that there is still an open issue about the palette. See here: https://bugs.scummvm.org/ticket/12050

comment:11 by vvs-, 21 months ago

Unfortunately this is not the right midi track at all. Neither are those numbers printed in debug log.

comment:12 by mgerhardy, 21 months ago

Reverted that commit. The entry 23 of ress.hqr is for the gif animations, it contains a string with the frames and the animation names. This was integrated into the engine. But i'm still unsure where to get the midi track id from.

---snip---
introd 2 4 6 8 10
baffe 12 14
baffe2 12 14
baffe3 12 14
baffe4 12 14
bateau 16 18
bateau2 16 20
flute2 22
navette 24
templebu 26 28 30
glass2 32
surf 34
verser 36
verser2 36
capture 38 40 42 44 46
neige2 48 50 52

dragon3 100

---snap---

newlines via \r\n

Just leaving this here as a reference.

comment:13 by mgerhardy, 20 months ago

flute2 contained an unimplemented opcode for playing a midi track 26 - this is implemented now in https://github.com/scummvm/scummvm/commit/fcbee4f724b5028cd1778aff375031b56b50dc40

comment:14 by vvs-, 20 months ago

Does it suppose to fix this issue? Because there is still no music after that commit.

comment:15 by vanfanel, 12 months ago

I can confirm there's still no music during intro movie play with current GIT version, so the issue is still there.

Last edited 12 months ago by vanfanel (previous) (diff)

comment:16 by mgerhardy, 12 months ago

Which version of the game are we talking about here? And which OS are you running the game on?

comment:17 by vvs-, 11 months ago

I can confirm this - no MIDI music in the intro movie. This is in commit d78295a8caba1e47343bc72f04a75b2ba3a4c7d6 on NixOS (Linux). Playing using USA CD version.

There is CD audio in menu and MIDI in the asylum, though. I can see the correct MIDI track 1 was selected in the source code right before the FLA movie. Still it didn't play for some reason.

comment:19 by mgerhardy, 10 months ago

The above posted line stops the music right after starting it - I suppose this call should go to mPLAY_FLA() and lPLAY_FLA() - and most likely removed from playMovie()

comment:20 by mgerhardy, 10 months ago

Should be fixed in 6f2c6531b4e2ca1643f1521f6a08384af681f41a and in the branch-2-5

comment:21 by mgerhardy, 10 months ago

Resolution: pending
Status: newpending

comment:22 by mgerhardy, 10 months ago

I still only hear the music if I extracted the tracks to ogg or mp3 - the midi files don't work at all for me. But I've never managed to get the midi working on any game so far. No clue about it - so might be my side. Feedback regarding midi would be nice.

comment:23 by vvs-, 10 months ago

Owner: changed from mgerhardy to vvs-
Resolution: pendingfixed
Status: pendingclosed

Fixed, thanks!

Both MIDI and CD audio tracks are working for me. I have this line at the beginning of the ScummVM log: Use midi_mi.hqr for midi. There is yet another file midi_sb.hqr which I believe was used in DOS for SoundBlaster cards.

This particular MIDI track used in that FLA movie doesn't sound very good, though. It's much better in DOSBox. But that might be just my particular set up as well.

Note: See TracTickets for help on using tickets.