Opened 16 years ago

Closed 16 years ago

#1203 closed defect (fixed)

MONKEYVGA: No fourth part / hangs at music

Reported by: SF/mr-maniac Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

ScummVM-Version: 0.5.3cvs (August 31 2003)
Platform: Windows
Bug: No fourth (4th) part

I have the german Floppy-Version of MonkeyVGA and when
I completed the first three parts, I won't come to the
fourth part...
The "title"-screen (Teil 4: Das Finale) appears, and
then... nothing... it "hangs" there... But ScummVM
still works...
I have this bug since a 0.5.3cvs Version.. I don't know
exactly WHAT 0.5.3cvs Version...

And I can't find the savegame... It isn't in my ScummVM
directory and it isn't in the Monkey Island 1 directory...

Ticket imported from: #797909. Ticket imported from: bugs/1203.

Attachments (1)

monkeyvga.s01 (62.0 KB) - added by SF/mr-maniac 16 years ago.
This is the Savegame... It's named "Bla"…

Download all attachments as: .zip

Change History (11)

comment:1 Changed 16 years ago by fingolfin

Save games are in your save game directory. The default one is
where your ScummVM is. But you can override this... look into
your scummvm.ini file for the save path

comment:2 Changed 16 years ago by fingolfin

Can't work on this w/o a proper savegame.

comment:3 Changed 16 years ago by fingolfin

Status: newpending

Changed 16 years ago by SF/mr-maniac

Attachment: monkeyvga.s01 added

This is the Savegame... It's named "Bla"...

comment:4 Changed 16 years ago by SF/mr-maniac

Status: pendingnew

comment:5 Changed 16 years ago by SF/mr-maniac

Okay... It took a long search... But now I've found the
Savegames...

comment:6 Changed 16 years ago by fingolfin

Owner: set to SF/jamieson630
Summary: MONKEYVGA: No fourth partMONKEYVGA: No fourth part / hangs at music

comment:7 Changed 16 years ago by fingolfin

OK thanks. I can reproduce the problem with your save game. Of
interest is that just when the "Part IV" music ends, this message
appears on the console:
ERROR! Bad command or running status 64
This is obviously generated by MidiParser::onTimer. Jamieson,
any clue on this one?

comment:8 Changed 16 years ago by Kirben

The problem is specific to native MIDI output, ScummVM
seems to be having a problem playing the RO sound resource
in this location.
Can use a boot param. of 8888 to get to the correct right.

comment:9 Changed 16 years ago by Kirben

Owner: changed from SF/jamieson630 to Kirben
Resolution: fixed
Status: newclosed

comment:10 Changed 16 years ago by Kirben

I had the RO sound resource size set wrong for blocked
games, fixed in ScummVM cvs.

Note: See TracTickets for help on using tickets.