#12029 closed defect (fixed)

SCUMM: COMI: Rottingham ship in the first cutscene of Part 3 goes the wrong direction

Reported by: AndywinXp Owned by: AndywinXp
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Monkey Island 3

Description (last modified by AndywinXp)

ScummVM version: 2.2.0 and latest dev builds
COMI version: Italian and English

Bug: At the start of part 3 there's a cutscene in which Guybrush gets his ship boarded by Captain Rottingham. During this cutscene there are two camera shots which show the two ships getting closer. In the original interpreter, in the first shot, Rottingham ship gets closer by reaching the Sea Cucumber by "walking" vertically towards it (up), while in the second shot, Rottingham ship gets closer by walking horizontally towards our ship (right). In ScummVM the first shot works fine, but in the second one, Rottingham ship refuses to go right (but it can go the other directions just fine, by imposing those via code) and just goes up instead, clipping with our ship sprite.

How to reproduce: just start Part 3.

PLEASE NOTE: this appears to be a SCUMM walkbox/path-finding related bug (the ship finds an obstacle on the right, so to reach the destination it just goes in the up direction), since it also affects Full Throttle in a different way (softlocking the game...) (see ticket #12030)

Check the video in the attachments!

Attachments (1)

Cmi Bug-1.m4v (858.8 KB ) - added by AndywinXp 20 months ago.
Video of the bug (the shot affected)

Download all attachments as: .zip

Change History (4)

comment:1 by AndywinXp, 20 months ago

Description: modified (diff)

by AndywinXp, 20 months ago

Attachment: Cmi Bug-1.m4v added

Video of the bug (the shot affected)

comment:2 by AndywinXp, 20 months ago

Description: modified (diff)

comment:3 by AndywinXp, 13 months ago

Owner: set to AndywinXp
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.