Opened 4 months ago

Closed 4 months ago

#12022 closed defect (fixed)

SCUMM: FT: skipping a cutscene also skips the first bike fight

Reported by: AndywinXp Owned by: AndywinXp
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Full Throttle

Description

Version: 2.2.0 but also the latest dev build.

How to reproduce: just after you retrieve the keys for your bike from the bartender, use the keys from the bike; a SMUSH video will start; press ESC to quit the cutscene.

The bug: pressing ESC will skip the cutscene, but will also skip the whole first bike fight; the game will jump to the winning sequence. This unintended behaviour creates at least one side effect: the SCUMM scripts which handles playing wind SFX outside the bar is never stopped, so those SFX will be present during the rest of the game (or until, for some reason, another script stops them).

I have already fixed this and I'll be sending a PR soon; I'm just filing this so I have a bug reference number to put into code.

Change History (1)

comment:1 by AndywinXp, 4 months ago

Owner: set to AndywinXp
Resolution: fixed
Status: newclosed

The fix has been merged, closing.

Note: See TracTickets for help on using tickets.