Opened 18 months ago

Closed 7 months ago

#12020 closed defect (fixed)

TWINE: Rendering artifacts if 3d model is clipped

Reported by: mgerhardy Owned by: mgerhardy
Priority: normal Component: Engine: TwinE
Version: Keywords:
Cc: Game: Little Big Adventure

Description (last modified by mgerhardy)

Whenever parts of an actor are clipped, there are pixels written at the 0 position of the x any y axis that shouldn't be there. This looks like an off-by-one bug somewhere is the 3d model rendering clipping code.

Attachments (3)

scummvm-lba-de-00009.png (134.5 KB ) - added by mgerhardy 18 months ago.
scummvm-lba-de-00008.png (50.2 KB ) - added by mgerhardy 18 months ago.
scummvm-lba-de-00007.png (121.6 KB ) - added by mgerhardy 18 months ago.

Download all attachments as: .zip

Change History (11)

by mgerhardy, 18 months ago

Attachment: scummvm-lba-de-00009.png added

by mgerhardy, 18 months ago

Attachment: scummvm-lba-de-00008.png added

by mgerhardy, 18 months ago

Attachment: scummvm-lba-de-00007.png added

comment:1 by mgerhardy, 18 months ago

Description: modified (diff)

comment:2 by sev-, 18 months ago

Summary: Rendering artifacts if 3d model is clippedTWINE: Rendering artifacts if 3d model is clipped

comment:3 by mgerhardy, 16 months ago

Should be fixed in latest master.

comment:4 by mgerhardy, 16 months ago

Owner: set to mgerhardy
Resolution: fixed
Status: newpending

comment:5 by mgerhardy, 10 months ago

Resolution: fixed
Status: pendingnew

The issue is still visible in the credits sequence.

comment:6 by mgerhardy, 10 months ago

Description: modified (diff)

comment:7 by mgerhardy, 7 months ago

a0262ed13b2f27bbb243f1bde63cf944b3b2f199 fixes another clipping issue

comment:8 by mgerhardy, 7 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.