Opened 18 years ago

Closed 18 years ago

Last modified 13 months ago

#12 closed defect

Atlantis and Monkey1 crash on startup

Reported by: SF/kartoffelsalat Owned by: SF/strigeus
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

I downloaded the current sources pre-alpha-0.0.2 and
changed the "monkey2" string in the main method to
"atlantis". error message:

1 1, 2 2, 4 4 4, 20 38 24 12 20 19556
WARNING: stub setShake(0)!
Loading cursor 0
Error(1): roomops:14 not implemented!
Press a key to quit.

Monkey1 does not work either. I get the following
error meesage:

1 1, 2 2, 4 4 4, 20 38 24 12 20 19556
Error(0): askForDisk: not yet implemented!
Press a key to quit.

BTW: Monkey2 works and I'm "working" under Linux

Ticket imported from: #477877. Ticket imported from: bugs/12.

Change History (6)

comment:1 by SF/pigeon, 18 years ago

I have monkey 1 working.
What I've done is to keep "monkey2", and create symlink for
monkey.000 and monkey.001 to monkey2.000 and monkey2.001

comment:2 by SF/kartoffelsalat, 18 years ago

I don't have the .000 and .001 files from monkey 1 -
instead I have many disk1.lec to disk4.lec, 000.lfl, and
901.lfl to 904.lfl.
I also tried atlantis with symlinking - that didn't work
either.

comment:3 by SF/kartoffelsalat, 18 years ago

I just checked out cvs version: atlantis works now!

but where do i get monkey1.000 and monkey1.001. Can I
combine them using my lfl and lec files?

comment:4 by SF/strigeus, 18 years ago

Owner: set to SF/strigeus
Status: newclosed

comment:5 by SF/strigeus, 18 years ago

1) Always use the CVS version, the others are outdated.
2) ScummVM does not work with Monkey 1 floppy version, the
CD version is required.

comment:6 by digitall, 13 months ago

Component: Engine: SCUMM
Note: See TracTickets for help on using tickets.