Opened 3 months ago

Last modified 5 weeks ago

#11998 new defect

AGOS: Elvira 2 - Inventory bug

Reported by: michas0602 Owned by:
Priority: normal Component: Engine: AGOS
Version: Keywords: Elvira 2 inventory mousescroll
Cc: Game: Elvira 2

Description

I am using a cracked Amiga version - not sure if the version of Elvira is causing this, or ScummVM, but I assume mouse-scrolling of ScummVM is causing this:

After playing a while, my inventory behaves strange - the items does not fit anymore to the texts - it shows a knive for example but if I click it and examine, it says "fire extingusher" etc. - so its unplayable after a while as the inventory is completely 'jumbled up'.

Possibly has to do with mouse-scrolling with mousewheel in the inventory?

Attachments (1)

IMG_20201206_213833-01.jpeg (147.8 KB ) - added by michas0602 3 months ago.

Download all attachments as: .zip

Change History (4)

by michas0602, 3 months ago

Attachment: IMG_20201206_213833-01.jpeg added

comment:1 by michas0602, 3 months ago

After some more testing I can say that Elvira 1 + Waxworks seem to work / are not affected.
For Elvira 2: I've tried x versions, cracked and uncracked - and all of them have the mousescroll problem, so I assume its a bug in the mousescroll-routine.

comment:2 by sev-, 2 months ago

Summary: Elvira 2 - Inventory bugAGOS: Elvira 2 - Inventory bug

comment:3 by michas0602, 5 weeks ago

Keywords: mousescroll added

I've seen User Athrxx committed a change to the menuscroll of Agos, but it has not affected this bug. I did a fresh compilation of ScummVM today, still the same error in Elvira 2 when scrolling the inventory with mousewheel.

Note: See TracTickets for help on using tickets.