Opened 3 months ago

Closed 3 weeks ago

#11995 closed defect (worksforme)

BACKENDS: ANDROID: Starship Titanic 1.00.42b crashes on Android 10

Reported by: LumenAstralis Owned by: antoniou79
Priority: blocker Component: Port: Android
Version: Keywords: Android, Starship Titanic
Cc: Game: Starship Titanic

Description

Version: ScummVM 2.2.1pre (Oct 25 2020 11:40:46)
Platform: Android 10 on Galaxy Note 9
Game: Starship Titanic 1.00.42b
Issue: Crashes and exits ScummVM at the beginning when the DoorBot gives you PET. The same game files run fine on the PC version of ScummVM.

Change History (5)

comment:1 by antoniou79, 3 months ago

I don't own the game, not on Steam nor on GOG (yet).
Is this the version that those stores offer?
It says here that the latest version is 1.00.42c

https://www.pcgamingwiki.com/wiki/Starship_Titanic
http://www.starshiptitanic.com/game/patches.html

comment:2 by antoniou79, 2 months ago

I recently had the chance to test Starship Titanic (Steam version) (detected as Windows/English) on a physical Android 10 device.

I tested with the ScummVM 2.2.1pre (Oct 25 2020 11:40:46) Play Store version, and the game launched fine, and played fine past the point of acquiring PET and writing with it. I went on the ship and saved the game. Later I also restored this save game to continue playing.

For the record Steam appears to have the latest patch (1.00.42c) pre-installed. I did not alter the game's directory when Steam installed the game, in any manner whatsoever. I just copied it to the SD card of my smartphone.

I have not encountered the crash of this report and I cannot reproduce it, which leads me to think that the issue may have been elsewhere (some background task? cloud synch? ScummVM's autosaving?).

I will test also with the recent daily development build to see if anything different comes up.

Last edited 2 months ago by antoniou79 (previous) (diff)

comment:3 by sev-, 8 weeks ago

Summary: Starship Titanic 1.00.42b crashes on Android 10BACKENDS: ANDROID: Starship Titanic 1.00.42b crashes on Android 10

comment:4 by antoniou79, 6 weeks ago

Please provide further feedback and details on this issue.

  • Does the crash persist for you (or anyone else)?
  • Does it always happen at that specific point near the start of the game?
  • Are you using some special configuration/settings for the game (overriding the default global ones)?

Since I cannot reproduce it on any of my attempts and devices, I am considering closing the ticket with a "worksforme" resolution. I will allow for a couple of weeks time, for possible additional feedback on the issue. If by February (2021) we don't have any, then I will close this.

comment:5 by antoniou79, 3 weeks ago

Owner: set to antoniou79
Resolution: worksforme
Status: newclosed

Closing this one, as I cannot replicate it and no further feedback was offered.

Note: See TracTickets for help on using tickets.