Opened 8 weeks ago

Closed 7 weeks ago

#11979 closed defect (fixed)

WEB: Broken link to FOTAQ download

Reported by: SupSuper Owned by: criezy
Priority: normal Component: Web
Version: Keywords:
Cc: Game: Flight of the Amazon Queen

Description

In the games download page, the link to the "Flight of the Amazon Queen - Freeware CD Version (unmodified original)" doesn't work: https://www.scummvm.org/games/#games-queen

Seems it's supposed to link to an external site, maybe it should be hosted in scummvm.org instead? In case the link goes down.

Change History (3)

comment:1 by criezy, 7 weeks ago

We have the same issue with the Broken Sword Brazilian cutscene pack that is hosted by the group who made it. In both cases frs/extras gets automatically added in from of the external URL in the game_downloads.yaml page, making the URL invalid. There is a header in this page that says it is generated automatically and should not be edited. I have no idea where the source for it is, but my guess is that it is correct and the issue is in the code that generates this page.

For the FOTAQ download, I think we could host it, which would fix the issue. I suspect we did not host it initially because at the time we had limited bandwidth (same reason we did not initially host the BS 2.5 download). But that is no longer an issue.

But hosting 3rd party content might be more tricky, so we may want to fix the code that generate the game_dowloads.taml page anyway.

comment:2 by criezy, 7 weeks ago

Actually the links were wrong on the source document, but were fixed a few days ago. However the web site has not been updated yet.

I have also uploaded the unmodified original FOTAQ version to frs, and updated again the link in the source spreadsheet. So next time the web site is updated, this one should be correct.

I am not sure though that external links are correctly handled, even if they are correct in the spreadsheet. I guess we will see that with the BS Brazilian cutscene pack once the web site has been updated.

comment:3 by criezy, 7 weeks ago

Owner: set to criezy
Resolution: fixed
Status: newclosed

I uploaded the unmodified FOTAQ version to frs and this is now the one being linked to from our download page.

I also checked that the external link for the Broken Sword Brazilian cutscene pack is now correct as well.

Note: See TracTickets for help on using tickets.