Opened 8 weeks ago

Closed 7 weeks ago

#11976 closed defect (fixed)

Versailles 1685: German umlauts

Reported by: laenion Owned by: lephilousophe
Priority: normal Component: Engine: Cryomni3D
Version: Keywords:
Cc: laenion Game: Versailles 1685

Description

It seems that the ingame texts are missing all German umlauts (ä, ö, ü, ß) - see the attached screenshot for an example - the character above the curser should be an 'ß', the character to it's left should be an 'ä'. This does not only affect the encyclopedia entries, but also the multiple choice dialogues and subtitles.

This is the German Ravensburger Windows version.

Attachments (1)

scummvm-versailles-fallback-00000.png (276.2 KB ) - added by laenion 8 weeks ago.

Download all attachments as: .zip

Change History (4)

comment:1 by laenion, 8 weeks ago

Speaking of it I just noticed that the broken formatting next to the image is caused by a suspicious line break where a 'ç' should be displayed, and the 'Mus?e' should probably be a 'Musée', so it seems all non-ASCII characters are affected.

comment:2 by lephilousophe, 7 weeks ago

Owner: set to lephilousophe
Resolution: pending
Status: newpending

Thanks for noticing this.

Problem comes from rewrite of string encoding stuff and I just realized that it's broken for all languages.
Working on a fix right now.

comment:3 by lephilousophe, 7 weeks ago

Resolution: pendingfixed
Status: pendingclosed

Should be fixed with commit 83b7fe01eac2898f96a2d55057be4d83f5cbdb0a

You will be able to test with next nightly build.

Note: See TracTickets for help on using tickets.