Opened 9 days ago

Last modified 8 days ago

#11961 new defect

No title bar on ScummVM window when switching out of fullscreen (OpenGL)

Reported by: Kurufinwe21 Owned by:
Priority: normal Component: Graphics
Keywords: Cc:
Game:

Description

ScummVM 2.3.0git10390-g5cf197d539 on Windows 10

Steps to reproduce:

  1. In the ScummVM options, turn on fullscreen mode, and set the graphics mode to OpenGL;
  2. Quit then restart ScummVM; it launches in fullscreen;
  3. Get out of fullscreen, either through the Options menu or by hitting Alt-Enter.

Result: ScummVM switches to windowed mode, but the window lacks a title bar; it looks out of place and cannot be dragged around. (See attached screenshot.)

Right-clicking ScummVM in the taskbar and selecting Move turns the cursor to the cross icon, but that doesn't let the window move.

However, the window can be resized by dragging the sides, and that makes the title bar appear.

Notes:

  • If ScummVM is started in windowed mode, the bug doesn't occur even if you switch in and out of fullscreen.
  • This only seems to occur with the OpenGL renderer. Things work properly with 2x, HQ2x, etc.
  • This is on Windows 10. No idea if the problem occurs on other OSes.
  • This has been happening for a while (possibly years); I should probably have reported it sooner.

Attachments (1)

buggy window.png (1.4 MB ) - added by Kurufinwe21 9 days ago.

Download all attachments as: .zip

Change History (3)

by Kurufinwe21, 9 days ago

Attachment: buggy window.png added

comment:1 by antoniou79, 8 days ago

I can't seem to reproduce with ScummVM 2.2.0 stable or my local build of ScummVM 2.3.0git.
Starting in fullscreen (OpenGL) switches back to normal window with a title bar for me.

The only thing close to the described behavior in the OP, happens for me when using a multi-screen set up, whereby for a brief second, switching out of fullscreen I see the ScummVM window without a title bar (which also appears in the wrong screen), but then it subsequently fixes itself (on its own) and appears with a title bar, and in the correct screen.

This is on Windows 10 x64 version 20H2, build 19042.630, all updates installed. Using an NVidia 1060 GTX card.

comment:2 by Kurufinwe21, 8 days ago

Ugh. I was hoping it wouldn't end up being system-specific.

Alright, my specs:

  • Windows 10 Home x64 version 20H2, build 19042.630
  • GeForce GTX 1060 3GB, driver version 457.30
  • Single LCD monitor, 1920x1080

The bug occurs when using:

Removing my scummvm.ini to start from scratch and following the steps from the original report is enough to reproduce the bug. Here are the contents of the file in that case:

[scummvm]
gui_browser_native=true
filtering=false
opl_driver=auto
mute=false
gui_use_game_language=false
speech_volume=192
last_fullscreen_mode_height=1080
mt32_device=null
midi_gain=100
local_server_port=12345
last_fullscreen_mode_width=1920
talkspeed=60
gfx_mode=opengl
tts_enabled=false
tts_voice=-1
subtitles=false
multi_midi=false
fullscreen=true
gm_device=null
sfx_volume=192
music_volume=192
autosave_period=300
music_driver=auto
native_mt32=false
vsync=true
aspect_ratio=false
versioninfo=2.3.0git10425-g3a2ea1db23
speech_mute=false
enable_gs=false

One curious detail I might note is that, the first time I switch out of fullscreen after launching ScummVM, my monitor goes black for a couple of seconds, which is usually what happens when the resolution or frame rate change. It doesn't happen again when going in and out of fullscreen afterwards, nor does it happen when initially launching ScummVM -- only the first time I switch out of fullscreen mode. This behaviour doesn't make a lot of sense to me, and I wonder if it is related to the bug.

I can't think of any other details that might be relevant, but feel free to ask for more info if necessary.

Note: See TracTickets for help on using tickets.