#11956 closed defect (fixed)

SCUMM: COMI - Wally's theme starting from wrong region after cannon battle

Reported by: AndywinXp Owned by: AndywinXp
Priority: normal Component: Engine: SCUMM
Version: Keywords: imuse digital comi cmi
Cc: Game: Monkey Island 3

Description

This happens during part 1: after destroying the last boat in the cannon minigame ("Hey, I'm getting pretty good at this!"), the game triggers a "seqLastBoat" iMUSE sequence, immediately followed by a SEQ_NULL.

The effect of this is that the music track ("stateCannon") changes region, playing a kind of "ending" part, and the SEQ_NULL concurrently fades this ending.

After the SEQ_NULL, the "stateHold2" music is called (Wally's theme), with a hookId which should result in a JUMP iMUSE instruction with ID = 1.

This means: start Wally's theme, but as soon as the intro drum roll is finished, JUMP to the refrain (chorus? main theme?) of the song, effectively skipping the remaining intro.

This kind of works in ScummVM, but for some reason Wally's theme starts from region 0 (which is empty, so complete silence), creating an awkward silence between the previous transition and the new track.

I couldn't track down the cause for the bug, but I guess it might be an edge case of region switching? I don't know, this doesn't seem to happen anywhere else in the game.

Attachments (2)

Originalexe.mp3 (419.1 KB ) - added by AndywinXp 14 months ago.
ScummVM.mp3 (631.9 KB ) - added by AndywinXp 14 months ago.

Download all attachments as: .zip

Change History (4)

by AndywinXp, 14 months ago

Attachment: Originalexe.mp3 added

by AndywinXp, 14 months ago

Attachment: ScummVM.mp3 added

comment:1 by AndywinXp, 14 months ago

I've attached audio examples for the bug.

Last edited 14 months ago by AndywinXp (previous) (diff)

comment:2 by AndywinXp, 14 months ago

Owner: set to AndywinXp
Resolution: fixed
Status: newclosed

Solved in the latest builds after adding some (unimplemented before) iMUSE Triggers

Note: See TracTickets for help on using tickets.