Opened 4 weeks ago

Closed 4 weeks ago

#11942 closed defect (fixed)

MYST3: Game doesn't start if subtitles is enabled

Reported by: eriktorbjorn Owned by:
Priority: normal Component: Engine: Myst3
Keywords: Cc:
Game: Myst 3: Exile

Description

If subtitles are enabled, Myst III errors out with the following message when I press "New Game":

Unknown subtitles font face 'Arial Narrow'!

This message comes from FontSubtitles::loadResources(), which at first glance seems odd because the first thing it does is to check if _fontFace equals "Arial Narrow".

But apparently these strings aren't equal, because _fontFace.size() is 13, while the string it creates to compare with gets size 12. So in the _fontFace string, it also counted the string terminator when it calculated the size?

I don't know if this is a regression or not. It's the first time I try to run Myst III in ScummVM.

It's the DVD version of Myst III, if that makes any difference.

Change History (1)

comment:1 by eriktorbjorn, 4 weeks ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.