Opened 4 months ago

Closed 4 months ago

Last modified 3 months ago

#11921 closed defect (duplicate)

Zak McKracken Plane Scene Time elapses too fast to solve tasks

Reported by: Alex170375 Owned by: bluegr
Priority: blocker Component: Engine: SCUMM
Version: Keywords: Gamespeed to fast
Cc: Game: Zak McKracken

Description

ScummVM version 2.2.0

Zak McKracken: If you enter the Plane the first time, the flight ends in a very short time. There are only a few actions possible and you aren't able to solve the tasks in the Plane. Is there a way to slow down the Emulation?

ZackMcKracken and the Alien Mindbenders, V2/DOS/German
Operating System macOS 10.15.7

Next, select the game in the 'Game' dropdown, and the game engine or other component in the 'Component' dropdown. Enter your text, and hit the button!

Attachments (2)

zak-v2-de.s04 (8.3 KB ) - added by Alex170375 4 months ago.
Savegame before Plane
zak-v2-de.s05 (7.0 KB ) - added by Alex170375 4 months ago.
After entering Plane, before Speech, 30 Seconds before flight ends ;-)

Download all attachments as: .zip

Change History (15)

by Alex170375, 4 months ago

Attachment: zak-v2-de.s04 added

Savegame before Plane

comment:1 by BenCastricum, 4 months ago

Isn't this the same as #3110?

comment:2 by Alex170375, 4 months ago

Dear BenCastricum, seems so.

Only On MacOS. Thanks for the info!

Last edited 4 months ago by Alex170375 (previous) (diff)

comment:3 by bluegr, 4 months ago

Owner: set to bluegr
Resolution: duplicate
Status: newclosed

Closing as duplicate of #3110

comment:4 by BenCastricum, 4 months ago

Well, still a decent description of what happens could help. What happens when you ran out of time? Do you get the "We are now landing. Prepare to disembark." (or something like that in German in this case) cutscene? if we know what scripts runs too soon, then we are one step closer to finding the cause.

comment:5 by Alex170375, 4 months ago

After you stand up (you got the peanuts) Zak enters the Airport. Three is no Massage that the plane is landing or anything else. Sometimes you make it to the toilet, sometimes you make it to the microwave. The time the flight ends is different.

comment:6 by BenCastricum, 4 months ago

Can you also add a savegame from when you just entered the plane? Before the stewardess starts with speech?

by Alex170375, 4 months ago

Attachment: zak-v2-de.s05 added

After entering Plane, before Speech, 30 Seconds before flight ends ;-)

comment:7 by Alex170375, 4 months ago

Tried something different (new) today:

Downloaded the FM-Towns-Version on gog. The problem is the same, but slightly different. You have here more time than in the MS-Dos-Version. In the FM-Towns Version you can stand up, stuff the sink, make it back to the microwave and let the egg explode. You can even take the cushion and the lighter. Now the Massage occurs that the plane is landing (this is missing in the Dos-version).

comment:8 by BenCastricum, 4 months ago

I also have the gog version. Could you try this:
Once in the plane, open the ScummVM debugger (~ key on a PC, probably also on a Mac)
type "scripts" to see the scripts currently running. Script number 212 (2nd column) should be one of them.
Type "script 212 stop" to stop that script. Then to return to your game type "quit" or hit the escape key.
This should give you unlimited time in the plane.

Last edited 4 months ago by BenCastricum (previous) (diff)

comment:9 by Alex170375, 4 months ago

Hi Ben,

tried this, but no effect at all. On Mac the Command for the debugger is control-option-d.

The Fm-Towns Version has the script, but stopping it had no effect at all. I tried it on three flights, you are able to stuff the sink but then the plane lands. It seems the flight is even shorter the second and third time. On the German MS-Dos Version the scripts are different, tried a bit but same here: It was worth a try, but, sorry, it didn't help.

comment:10 by BenCastricum, 4 months ago

Hi Alex, I tried your DOS savegames with some other V2 version of the game, but the data is not compatible. So I can't reproduce the issue with these savegames. I don't have a compatible game.

But if the GOG version shows similar behavior, we can work with that. Script 212 is the 8 minute timer, so if killing it doesn't help, something else triggers the end of flight (script 201).
In the debugger, there is also a "debug +script" command which logs in the console window which script is started by which script. Do you have the possibility to copy that info? The logging from when you are in the plane till the announcement of the plane is landing would be very helpfull. It should contain a runScript(201) from XX-YY line somewhere. The XX-YY part is the important part, but the logging leading up to it may also contain valuable info.
And perhaps a savegame from the GOG version of when you are in the plane could help too.

You can also PM me the info, you have my email :)

comment:11 by Alex170375, 4 months ago

Hi Ben, I will try this in the evening, but I solved the problem in a very different way:

I used Parallels Desktop to emulate Windows XP on the Mac. Then I installed the latest Version of SCUMMVM for Windows XP. Assigned the same Folders of the Zak's to the emulated Emulator (my very own version of SimSim... ;-) )... and, it worked.

On Windows XP via Parallel with Scumm VM

  • the FMTowns Version works perfect, the flight ist really long and you can solve the tasks even without use the microwave
  • the english Dos Version does the same, the flight ist very long and you can solve all tasks
  • the german Dos Version is a bit different: the first time it was the same problem, the flight was a bit short so you couldn't open all the compartments to grab the oxygen. The second time I tried it the version behaved like the two others, a lot of time, but you had to use the microwave.

So, the problem seems to affect only the OSX-Version of Scumm.

Now I have three Savegames, so I can go on in the game ;-).


comment:12 by Alex170375, 3 months ago

Hi Ben,

I had a lot of work so I couldn’t write earlier.

Here are the Scripts:

Scripts when entering the Plane, before Speech:

Zak McKracken and the Alien Mindbenders, FM-Towns, english

+——-—————————————————----------------------------------————-+
| # | num| offst | sta | typ | fr | rec | fc | cut |
+—-----+—---——+—------——-+—----+---—-+—---+—---—-+—---+—---—+
| 1 | 57| 0000e| 129| 2| 0| 0| 1| 0|
| 2 | 8| 0000a| 129| 2| 0| 0| 1| 0|
| 3 | 10002| 1321e| 13| 1| 0| 0| 1| 0|
| 4 | 216| 14330| 2| 3| 1| 0| 0| 0|
| 5 | 49| 0000f| 129| 2| 0| 0| 1| 0|
| 6 | 56| 00025| 129| 2| 0| 0| 1| 0|
| 7 | 212| 14097| 1| 3| 1| 0| 0| 0|
| 8 | 202| 135dc| 1| 3| 0| 0| 0| 1|
| 12 | 211| 0971a| 0| 3| 1| 0| 0| 0|
| 13 | 212| 09761| 0| 3| 1| 0| 0| 0|
| 14 141| 001cc| 130| 2| 0| 0| 1| 0|

Scripts after Cutscene, Zak can do Tasks:

+——-—————————————————----------------------------------————-+
| # | num| offst | sta | typ | fr | rec | fc | cut |
+—-----+—---——+—------——-+—----+---—-+—---+—---—-+—---+—---—+
| 1 | 57| 0000e| 1| 2| 0| 0| 0| 0|
| 2 | 8| 0000a| 1| 2| 0| 0| 0| 0|
| 4 | 216| 142ba| 2| 3| 1| 0| 0| 0|
| 5 | 49| 0000f| 1| 2| 0| 0| 0| 0|
| 6 | 56| 00025| 1| 2| 0| 0| 0| 0|
| 7 | 212| 14097| 1| 3| 1| 0| 0| 0|
| 9 | 203| 13848| 2| 3| 0| 0| 0| 0|
| 10 | 209| 13ef3| 2| 3| 1| 0| 0| 0|
| 12 | 211| 0971a| 0| 3| 1| 0| 0| 0|
| 13 | 212| 09761| 0| 3| 1| 0| 0| 0|

Scripts after Sounds changes and the Plane is landing:

+——-—————————————————----------------------------------————-+
| # | num| offst | sta | typ | fr | rec | fc | cut |
+—-----+—---——+—------——-+—----+---—-+—---+—---—-+—---+—---—+
| 1 | 57| 0000e| 129| 2| 0| 0| 1| 0|
| 2 | 8| 0000a| 129| 2| 0| 0| 1| 0|
| 4 | 216| 14330| 2| 3| 1| 0| 0| 0|
| 5 | 49| 0000f| 129| 2| 0| 0| 0| 0|
| 6 | 56| 00025| 129| 2| 0| 0| 1| 0|
| 7 | 212| 14097| 1| 3| 1| 0| 0| 0|
| 9 | 203| 13807| 130| 3| 0| 0| 1| 0|
| 10 | 209| 13f45| 1| 3| 1| 0| 0| 1|
| 12 | 211| 0971a| 0| 3| 1| 0| 0| 0|
| 13 | 212| 09761| 0| 3| 1| 0| 0| 0|

Everything you wrote had no effect I had to use the work-around with Windows.

Maybe this helps a little...

;-)

Last edited 3 months ago by Alex170375 (previous) (diff)

comment:13 by BenCastricum, 3 months ago

A bit, the last output conforms 212 (timer) has not reached the end. So something else is triggering the end of flight. The next step would be script logging, but I do not know how to do that on a mac.
I suspect it's a port specific bug, since I am unable to reproduce it on my Android phone, Linux or Windows machines. And if that's really the case the most likely way to find the cause will be some hardware breakpoint. In short, I don't think I can find the cause without any way to reproduce it in a development environment. It's good that you found a way around it :)

Note: See TracTickets for help on using tickets.