Opened 21 months ago

Closed 9 months ago

#11897 closed defect (invalid)

GRIM: Black window/screen on mode switch (ALT+ENTER) (SDL1)

Reported by: raziel- Owned by: aquadran
Priority: normal Component: Engine: Grim
Version: Keywords:
Cc: Game: Grim Fandango

Description (last modified by raziel-)

ResidualVM 0.4.0git (Dec 31 2017 15:41:14)
Features compiled in: Vorbis MP3 RGB zLib MPEG2 Theora FreeType2 JPEG PNG

  • Start Grim Fandango
  • Press ESC to get right into the game
  • Press F1 to bring up the "menu" (game is paused)
  • Perform a mode switch (ALT+Enter) to switch to/from window/screen

One will end up with a black screen/window due to, what i think, is a missing screen/window redraw command after said mode switch. I guess it's not triggered because the game is in pause mode(?)

Pressing ESC or cursor up/down will trigger a redraw and all is fine again, but imho it's a bad idea to leave users with a black window/screen...at least i thought residualvm has crashed on me.

AmigaOS4 - SDL - BE - PPC
gcc (adtools build 5.4.0) 5.4.0

https://github.com/residualvm/residualvm/issues/1389

One funny thing i found out is that the demo displays this problem on both SDL1 and SDL2, while the full game suffers only in SDL1 from it.

Might this be an issue in the original data files?

I guess the game data affects how this issue occurs, but it's something we could fix properly regardless of game version.

Change History (4)

comment:1 by raziel-, 12 months ago

Description: modified (diff)
Summary: GRIM: Black window/screen on mode switch using SDL1GRIM: Black window/screen on mode switch (ALT+ENTER) (SDL1)

comment:2 by aquadran, 9 months ago

Which renderer? Does it happen in latest code base?
I tried with SDL1 with software renderer, no issue. I could not test it with OpenGL, SDL1 seems too old. I'll try on Linux or Windows.

comment:3 by raziel-, 9 months ago

OpenGL w/o shaders definitely.

Software renderer i don't really know (need to re-test, but if you say it works, that is probably not needed anyway anymore?).

The fact that i can't test it anymore, because SDL1 lost the ability to key-switch from window to fullscreen and vice-versa, I added in #12426.

comment:4 by aquadran, 9 months ago

Owner: set to aquadran
Resolution: invalid
Status: newclosed

that is correct with SDL1 fullscreen switching for OpenGL is not supported. So it's not a bug. You can switch only with software renderer.

Note: See TracTickets for help on using tickets.