Opened 21 months ago

Closed 9 months ago

#11894 closed defect (invalid)

GRIM: OpenGL renderer doesn't honor stretch mode in fullscreen

Reported by: eriktorbjorn Owned by: aquadran
Priority: normal Component: Engine: Grim
Version: Keywords:
Cc: Game: Grim Fandango

Description

I usually don't run ScummVM in fullscreen, prefering instead to run it in a window (usually with the "2x" graphics mode). But just in case I've configured Stretch mode to "Fit to window", because as I understand it that should fill the screen as much as possible while still preserving the game's aspect ratio.

This works fine for most games. Actually, it works fine for Grim Fandango as long as I use the TinyGL as my "Game 3D Renderer". But if I use OpenGL - with or without shaders - fullscreen stretches the game to fill the entire screen.

Is there some obvious way to preserve aspect ratio that I've missed?

(This may also affect other 3D games. I haven't tested.)

Change History (3)

comment:1 by eriktorbjorn, 9 months ago

This seems to be a regression after the ScummVM / ResidualVM merge. I tried it in ResidualVM, and there aspect ratio was preserved in fullscreen mode.

comment:3 by aquadran, 9 months ago

Owner: set to aquadran
Resolution: invalid
Status: newclosed

Stretch options are not for 3D games. 3D backend doesn't have scalers and never will have. "Aspect ration" should be used.

Note: See TracTickets for help on using tickets.