Opened 4 years ago

Closed 2 months ago

#11815 closed defect (duplicate)

GRIM: Lua error when opening locked door in year 3

Reported by: aquadran Owned by: aquadran
Priority: normal Component: Engine: Grim
Version: Keywords:
Cc: raziel- Game: Grim Fandango

Description (last modified by aquadran)

As the door opens this lua error happens. Manny stops being animated after it happens.

lua: (null)
Active Stack:

`gettable' tag method at line 2346 [in file Scripts\_system.lua]
function (Scripts\_actors.lua:749)
function (Scripts\_manny.lua:870)
function (Scripts\vd.lua:77)
function (Scripts\vd.lua:808)

WARNING: Lua: call expression not a function!
lua: (null)
Active Stack:

`gettable' tag method at line 2346 [in file Scripts\_system.lua]
function (Scripts\_actors.lua:749)
function (Scripts\_manny.lua:870)
function (Scripts\vd.lua:77)
function (Scripts\vd.lua:808)

I can reproduce with 0.1.1 too

Related #1234
#1234

https://github.com/residualvm/residualvm/issues/1138

Attachments (1)

6d912634-8dd8-11e4-9ca2-6160188a5d36.gsv (868.8 KB ) - added by aquadran 4 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 by aquadran, 4 years ago

Description: modified (diff)

comment:2 by raziel-, 4 years ago

Cc: raziel- added

comment:3 by arrowgent, 2 years ago

ah, i created another ticket for this

https://bugs.scummvm.org/ticket/13139

still an issue with scummvm v2.5.0

comment:4 by digitall, 2 months ago

Owner: set to aquadran
Resolution: duplicate
Status: newclosed

CLosing this as duplicate of the newer bug 13139 which has newer and more extensive information on this issue.

Note: See TracTickets for help on using tickets.