Opened 2 months ago

Last modified 8 weeks ago

#11758 pending defect (worksforme)

Pegasus prime demo: colossal memory leak, wan't start

Reported by: fedor4ever Owned by: sev-
Priority: low Component: Engine: Pegasus
Keywords: Cc:
Game: Journeyman Project Pegasus Prime

Description

scummvm-2.2.0-winxp-win32>scummvm.exe -v
ScummVM 2.2.0 (Sep 14 2020 10:41:13)

How reproduce: run demo, instead intro memory start leaking. This leak consume almost 2Gb Ram!

Os: windows, symbian.

ScummVM 1.8.1 run demo fine.

Change History (8)

comment:1 by sev-, 2 months ago

Owner: set to sev-
Resolution: worksforme
Status: newpending

I cannot reproduce. The memory usage goes from initial 300MB, eventually to 700MB. Did not see 2Gb on a 64bit Mac.

Please, provide more information. Also, since you're a developer, please run a MemoryDoctor on Windows and tell where do you see the memory leaks.

comment:2 by sev-, 2 months ago

Priority: highlow

comment:3 by fedor4ever, 2 months ago

First line in description: scummvm-2.2.0-winxp-win32
It means ScummVM 2.2.0 32 bit edition.

I try run Pegasus demo with ScummVM 2.2.0 on my symbian phone with memory monitor and see 2 things: black screen and free ram started disappear. App crashed when 10mb free ram ends.
I try 1.8.1 - memory doesn't disappear, demo runs fine.

I run Pegasus with on winxp x64 sp2 with task manager started. I see black screen free ram started disappear. When it feed 1974mb ram it stopped. No sounds, only black screen.

Do you say on mac os game use 400 mb? Can you try 1.8.1? I haven't mac.

comment:4 by criezy, 8 weeks ago

I tried the demo on Linux with both the current master and branch-2-2, and I can't see any issue. With branch-2-2, it uses 14.1 Mb before starting the game, and then a steady 22.7 Mb while playing. With master it uses a little more memory, 14.6 Mb before starting the game, and then 23.0 Mb while playing. And in both cases I still have plenty of free memory.

I also tried with valgrind, and it didn't detect any memory leak in the pegasus engine.

comment:5 by criezy, 8 weeks ago

And I also just tried on macOS 64 bits on branch-2-2 and while playing the pegasus prime demo ScummVM uses a steady 61.6 Mb (it uses 46.7 Mb before starting the game).

So I can't reproduce any bad memory leak either (neither on Linux, nor on mac).

comment:6 by fedor4ever, 8 weeks ago

Do you press start button? Do you try windows build? Try x64 version on win7 x64 - memory leaked too.

comment:7 by criezy, 8 weeks ago

Yes I did press the Start button.
And no I did not try the windows build (and I can't try it since I don't have a Windows computer).

comment:8 by fedor4ever, 8 weeks ago

Okay. Waiting someone else with windows computer.

Note: See TracTickets for help on using tickets.