Opened 6 months ago

Closed 6 months ago

#11751 closed defect (worksforme)

XEEN: Error starting with OpenGL

Reported by: Tucky27 Owned by: dreammaster
Priority: normal Component: Engine: Xeen
Version: Keywords:
Cc: Game: Might and Magic: World of Xeen

Description

I am using the GOG version of World of Xeen.

When using opengl as the graphics mode the game will not launch. It seems to work fine when not using this option. I tried this using a daily build (October 2nd) and the latest stable 2.2.0 with the same result.

The error message from the status window reads:
User picked target 'worldofxeen-1' (engine ID 'xeen' , game ID 'worldofxeen')...

Looking for a plugin supporting this target... Xeen

WARNING: cannot open parallel port 0x278!
WARNING: cannot claim parallel port 0x278!
WARNING: cannot open parallel port 0x378!
WARNING: cannot claim parallel port 0x378!
WARNING: cannot open parallel port 0x3bc!
WARNING: cannot claim parallel port 0x3bc!

You see a black screen and then ScummVM crashes.

Change History (3)

comment:1 by dreammaster, 6 months ago

I tried it locally without any problem. The likely culprit is some issue on your system, maybe with your graphic drivers. Maybe try running some other games with OpenGL, and see if you have similar issues

comment:2 by Tucky27, 6 months ago

I have tried again with the stable and latest daily build and it appears to be working fine. Not sure what caused the issue but its gone now.

comment:3 by dreammaster, 6 months ago

Game: Might and Magic: World of Xeen
Owner: set to dreammaster
Resolution: worksforme
Status: newclosed
Summary: World of XeenXEEN: Error starting with OpenGL

Good to hear it. I'm going to close the ticket

Note: See TracTickets for help on using tickets.