Opened 4 months ago

Closed 3 months ago

#11749 closed defect (fixed)

GLK: ZCode - Zork 1 bug after save and restore

Reported by: NoWayOuy Owned by: dreammaster
Priority: normal Component: Engine: GLK: ZCode
Version: Keywords:
Cc: Game: GLK Z-Code (Frotz) Game

Description (last modified by NoWayOuy)

Game file:zork 1 release 88 DOS version.
Scummvm 2.2.0
Windows 10 latest update

After playing an hour or so and accumulating 3 save games, trying to restore most recent save results in a bug that doesn't allow trapdoor to be opened or items to be picked up or dropped. Tried with most recent nightly with same result.

Taking this same save, created by scummvm, changing extension to .sav and loading it in Windows frotz results in perfectly working game.

To reproduce, load attached save in zork 1 release 88 and attempt to open trapdoor, or advance the game in any other way.

Attachments (1)

zork1-1.003 (800 bytes ) - added by NoWayOuy 4 months ago.

Download all attachments as: .zip

Change History (4)

by NoWayOuy, 4 months ago

Attachment: zork1-1.003 added

comment:1 by NoWayOuy, 4 months ago

Description: modified (diff)

comment:2 by raziel-, 3 months ago

Summary: Zork 1 zcode bug after save and restoreGLK: ZCode - Zork 1 bug after save and restore

comment:3 by dreammaster, 3 months ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

This should now be fixed in daily builds. There was an error in restoring the stack from savegames

Note: See TracTickets for help on using tickets.