Opened 7 months ago

Closed 3 weeks ago

#11722 closed defect (worksforme)

ZVISION: NEMESIS: Crash when looking at safe

Reported by: heumann Owned by: bluegr
Priority: normal Component: Engine: ZVision
Version: Keywords: crash, OS X
Cc: heumann Game: Zork Nemesis

Description

Hello! Thanks for all your hard work; I really appreciate the heck out of the ScummVM team.

I'm encountering a crash in Zork Nemesis. In the Asylum, I get the safe out of the freezer, put it in the machine next to the freezer and go to look at the front of the safe and the whole thing crashes. I've attached a save game to reproduce the bug, and the crash report from OS X.

ScummVM version: ScummVM 2.1.2 (Mar 31 2020 00:39:04)
Features compiled in: Vorbis FLAC MP3 SEQ TiMidity RGB zLib MPEG2 FluidSynth Theora AAC A/52 FreeType2 JPEG PNG cloud (servers, local)

Language of game: English
Version of game: DOS
Your OS: OS X 10.15.6 (19G2021)

Attachments (3)

crash_report.txt (73.6 KB ) - added by heumann 7 months ago.
znemesis.013 (17.3 KB ) - added by heumann 7 months ago.
crash_report_2020-09-29.txt (70.5 KB ) - added by heumann 7 months ago.

Download all attachments as: .zip

Change History (12)

by heumann, 7 months ago

Attachment: crash_report.txt added

by heumann, 7 months ago

Attachment: znemesis.013 added

comment:1 by antoniou79, 7 months ago

Component: --Unset--Engine: ZVision
Keywords: crash OS X added

comment:2 by raziel-, 7 months ago

Summary: Zork Nemesis crashes when looking at safeZVision: Nemesis - Crash when looking at safe

comment:3 by bluegr, 7 months ago

I'm unable to reproduce this bug. I place the safe, then check its front, and the safe puzzle opens normally. I've tried with both the CD and DVD versions. Which version have you got?

comment:4 by heumann, 7 months ago

This is the CD version; I followed the directions on the wiki and applied the subtitles patch and moved files around as instructed.

by heumann, 7 months ago

Attachment: crash_report_2020-09-29.txt added

comment:5 by heumann, 7 months ago

I just updated to 2.2.0, but the crash still happens. I'm attaching another crash report.

Thanks again for all your help! Even if we don't fix this (and I hope we do as I'm really enjoying this game), it's really lovely to file a bug report and actually get responses this quickly.

comment:6 by heumann, 6 months ago

I have a slight update. I realized that there were other areas I could visit in the game, and so completed the monastery and the conservatory, thinking that this might alter something in my save file that might avoid triggering this crash. The crash still happens, but in the conservatory I found out that some visual elements weren't displaying: the images for the instruments that are lying on the floor of the practice room weren't displaying (in fact I had to look up a video walkthrough before I realized they were supposed to be there). They also didn't appear when I placed the instruments on the chairs.

I wonder if my version of the CD content is missing a source file somewhere. If by any chance the images of those instruments are stored in the same place as the safe front, maybe that's the cause of my crash.

comment:7 by sev-, 4 months ago

Summary: ZVision: Nemesis - Crash when looking at safeZVISION:: NEMESIS: Crash when looking at safe

comment:8 by sev-, 4 months ago

Summary: ZVISION:: NEMESIS: Crash when looking at safeZVISION: NEMESIS: Crash when looking at safe

comment:9 by bluegr, 3 weeks ago

Owner: set to bluegr
Resolution: worksforme
Status: newclosed

I can't reproduce these issues, so it seems your copy of the game has corrupted data files.

Try buying a good copy from GoG or Steam. You can find links in our relevant wiki page:
https://wiki.scummvm.org/index.php?title=Where_to_get_the_games

Closing as worksforme

Note: See TracTickets for help on using tickets.