Opened 3 months ago

Closed 2 months ago

#11686 closed defect (invalid)

CINE: OS: Impossible to use inventory

Reported by: TheRealSpole Owned by: karisal
Priority: normal Component: Engine: Cine
Keywords: Cc:
Game: Operation Stealth

Description (last modified by TheRealSpole)

Operation Stealth DOS version.

It is not possible to use the inventory so in the first scene the briefcase can not be operated.

2.3.0git296-g8fc5450aae

Change History (5)

comment:1 by TheRealSpole, 3 months ago

Description: modified (diff)

comment:2 by karisal, 3 months ago

I assume that you are trying to use the inventory by first pressing the right mouse button to open the action menu ("EXAMINE", "INVENTORY" etc) and then pressing the right mouse button on the "OPERATE"-button in the menu and then another menu should open with the inventory which should contain the "Briefcase"-entry on which you'd press the left mouse button on. Is this correct?

I tried in this way with Operation Stealth 16 color DOS version but was unable to reproduce the bug with either the latest development build (2.3.0git315-g6a9ad2daf2 (Sep 8 2020 11:02:41)) or the latest stable build (2.2.0pre170-g41a1a487ea (Sep 8 2020 06:10:07)) from the buildbot for Windows 64-bit.

BTW if you wish to help in the release testing of the next release of ScummVM (2.2.0) then please use the stable builds for testing (2.2.0pre* instead of 2.3.0*), thank you! You can get the stable builds from the buildbot.

@TheRealSpole To check out which version of Operation Stealth you are using please could you download md5deep from ​​http://md5deep.sourceforge.net/
and then run the following in the directory where you have the game data files
for your version of Operation Stealth and give the output here into this ticket:

echo The listing of files including their sizes:
dir
echo MD5sums of the first 5000 bytes of each file:
md5deep -p 5000 * | find /i "offset 0-4999"
echo MD5sums of the full files:
md5deep *

The idea is to get the file sizes and names using "dir" command,
the MD5sums of the files' first 5000 bytes by the second command and
the MD5sums of the whole files by the third command.

Thank you!

comment:3 by karisal, 3 months ago

Component: --Unset--Engine: Cine
Game: Operation Stealth
Summary: STEALTH: Impossible to use inventoryCINE: OS: Impossible to use inventory

comment:4 by TheRealSpole, 3 months ago

I am very sorry, but I can not recreate the issue today. Hopefully it was just user issue. Was long time I played this game.

Running the 256 color DOS version. I will download the stable 2.2.0.

comment:5 by karisal, 2 months ago

Owner: set to karisal
Resolution: invalid
Status: newclosed

As neither I nor the bug reporter could recreate the issue I am closing this ticket as invalid.

Note: See TracTickets for help on using tickets.